Ha oído alguien si Oracle apoyo a la 10G cliente de Windows 7? Estoy obligado (muy reticentes desde que yo empecé en SQL Server) para lidiar con Oracle dev cada día y, desde el 7 es «solo un pulido de Vista» (que creo que es muy superior y he estado usando la Vista desde RTM) la teoría es que va a funcionar bien.

También, si este es el lugar equivocado para preguntar esto, por favor hágamelo saber. Ya que el dev-releated, no pensé que pertenecía ServerFault.

InformationsquelleAutor RubyHaus | 2009-07-30

3 Comentarios

  1. 1

    Tengo que trabajar (10.2.0.4) en Windows 7! Siguiendo las recomendaciones de los este blog he cambiado el XML y se instala el cliente (10.2.0.3 creo). Para instalar el conjunto de parches para 10.2.0.4 (le da transaccional apoyo en Vista/2008) ejecutar el instalador en modo de compatibilidad. Si bien no he tenido la oportunidad de probar la transaccional apoyo que me han, al menos, confirmó la Bentónicos herramienta de Oro funciona bien, que es más de lo que nunca he llegado antes.

    Esto fue hecho en Windows 7 x64 – cliente de Oracle es la versión x86, ya que no tienen una versión de 64 bits del conjunto de parches para transaccional de apoyo (ni existe en algunos sabores de 11G, sin embargo, que es posible).

    Espero que esto ayude a otros con el mismo problema!

  2. 0

    La derecho lugar para hacer probablemente sería el soporte de Oracle en foros, pero yo no voy a votar a los de cerca, ya que eran tan agradables en el último párrafo. Ver aquí.

    Este es probablemente el más útil. Básicamente, no hay apoyo, al menos hasta el Win7 va GA. Cuánto tiempo después de que antes de que Oracle tira sus cosas juntos y lo apoya, nadie lo sabe.

    Una posibilidad a tener en cuenta: he oído hablar de Microsoft iba a poner un administrador de máquinas virtuales en Win7 para intentar convencer a todos los XP juntas directivas, para actualizar. Que parece ser todavía el caso, como se documenta aquí y aquí en Microsoft propio sitio. Si es así, usted podría ejecutar Oracle 10g en virtud de la VM.

    • Así que, irónicamente, estoy digitall en el Oráculo de los Foros. Pregunté aquí porque la gente que lado de la valla son mucho menos que útil para decir lo menos (y no he visto una respuesta para que el hilo en una semana). Gracias por la respuesta!
  3. 0

    Vi este post y encontré el mismo problema. También vi tu post sobre aquí que dijo que fueron capaces de conseguir trabajo usando la opción ‘2’ que Justin Cueva sugerido. Fuiste capaz de conseguir que el trabajo? Podría usted describir el proceso en algo más de detalle?

    ACTUALIZACIÓN: Como un seguimiento, que en realidad eran capaces de hacerlo funcionar. He aquí cómo: crear un acceso directo con el ignoreSysPrereqs de la bandera en el ejecutable. Ejecute el archivo ejecutable como Administrador, y NO uso Vista o cualquiera de los modos de compatibilidad. También hemos instalado un adaptador de bucle invertido (como se describe aquí), aunque no sé si eso tuvo ningún impacto. Funciona como necesarios en los desarrolladores de máquinas y apreciamos la investigación que usted pone en este! 🙂

    • Cuando vayas a ejecutar su instalador (la que te hace recordar un poco acerca de Windows 95 UX y de lo bonito que era…) tienes que hacerlo desde un símbolo del sistema y agregar en el «-ignoreSysPrereqs» cambiar después de que el nombre del exe. Es sólo una especie de obras y aunque no he tenido mucha suerte con el RTM bien.
    • Como seguimiento, que en realidad eran capaces de hacerlo funcionar. He aquí cómo: crear un acceso directo con el ignoreSysPrereqs de la bandera en el ejecutable. Ejecute el archivo ejecutable como Administrador, y NO uso Vista o cualquiera de los modos de compatibilidad. También hemos instalado un adaptador de bucle invertido, como se describe aquí (windowsreference.com/windows-7/…), aunque no sé si eso tuvo ningún impacto. Funciona como necesarios en los desarrolladores de máquinas y apreciamos la investigación que usted pone en este! 🙂
    • También de la nota, usted tiene que comprobar manualmente y de ignorar los otros elementos que se enumeran en el proceso de instalación. No se preocupe – funciona.
    • Como seguimiento de este tipo de trabajo. Si por casualidad usted necesita el 10.2.0.4 conjunto de parches (permite transacciones distribuidas de trabajo), a continuación, Oracle no se apoyan en 7 o 2008 R2. Sólo le ayuda con la 11G cliente (certificación pendiente) y superior. Por supuesto, la 11G cliente no necesariamente tienen los mismos parches que 10G hace de manera que todos podamos estar de conmutación a SQL server en el futuro para conseguir una verdadera plataforma de base de datos (personalmente odio Oracle MUCHO).
    • Trabajó para fines de desarrollo, y eso es todo lo que necesitaba para. Gracias de todos modos por el seguimiento 🙂
    • 11g siendo la versión actual tiene todas las revisiones que se han añadido a 10g así. 11g instala bajo 7/2008 sin ningún tipo de problemas.

Dejar respuesta

Please enter your comment!
Please enter your name here