Sybase ASE ADO.net 2.0 proveedor?

Estoy en busca de un ADO.net 2.0 o posterior proveedor de base de datos de Sybase, que parece ser conocido como Sybase ASE. Para aclarar, estoy interesado en ASE, y no SQL Anywhere. Esperemos que el proveedor será incluido en la base de datos, o de forma gratuita.

Puedo encontrar mención de un ADO.net 1.1 proveedor; que no es lo que quiero.

Puedo encontrar la mención de los controladores ODBC y OLEDB de proveedores; que no es lo que quiero.

He encontrado la DataDirect ADO.net los proveedores que son pagadas; supongo que es la posición de retroceso.

Gracias por su ayuda

OriginalEl autor EC. | 2009-06-03

5 Kommentare

  1. 7

    Esta pregunta es bastante viejo pero parece que lo han hecho más fácil para obtener el ADO Conector.

    1. Descargar el «Obtener de forma Gratuita un «Desarrollador» Edición» de
      http://scn.sap.com/community/developer-center/oltp-db
    2. Seleccione la Instalación Personalizada cuando se les da la opción.
    3. Sólo instalar el .Net ADO paquete de instalación personalizada.
    4. De referencia de la Sybase.AdoNet4.AseClient.dll en su solución, desde donde la instalación colocar los archivos.

    A continuación, usted debe ser capaz de realizar consultas, actualizaciones, etc. en .NETO siguiendo las instrucciones de aquí:
    http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.help.sdk_12.5.1.adonet/html/adonet/DAFJEFIF.htm

    OriginalEl autor

  2. 10

    De haber sido recientemente abajo de este camino mí, sólo puedo sugerir que usted no encontrará la respuesta a través de la búsqueda de la red. Si se conecta a un servidor ASE, entonces usted tiene un cliente de contacto técnico. El uso que la persona, pidiéndoles a descargar los mencionados anteriormente, Sybase 15 #ESD10.

    Desde mi experiencia (que libremente he de admitir, fue un mal);

    Sybase hace que este tipo de desarrollador de recursos disponibles para el pago de los clientes solo.

    De la descarga, una vez que usted tiene, va a incluir un montón de extras que usted no necesita. Todavía creo que PowerDesigner es una gran utilidad, pero creo que lo que se incluye es una versión de prueba, de limitado valor a largo plazo. Yo creo que lo que quiere de la serie es la OpenClient instalar, seleccionar el ADO.NET características.

    Me encontré con toda la experiencia, desde la adquisición de los recursos de desarrolladores (sólo a identificar el derecho de descarga era una lucha), para aislar los dos archivos necesarios de los cientos de archivos instalados, el hecho de que la instalación se rompió mi existentes RapidSql y DbArtisan instala, y, finalmente, que la versión actual no va más allá de ADO.NET 2 compatibilidad con el proveedor (que no puedo conseguir EF cableado por ejemplo), para ser realmente frustrante.

    No es de extrañar entonces que no he sido capaz de encontrar mucho apoyo para ASE usando nHibernate o subsónico.

    Exactamente la misma experiencia para mí. Camino a seguir para llegar a más personas con tu mierda de producto – hacer que sea difícil, REALMENTE disco DURO para conectarse a ella. Tontos!
    Hofmann: no Podría estar más de acuerdo. Afortunadamente, parece que Sybase se va a morir. ==> la Evolución de Darwin trabaja para las personas jurídicas, también.
    Es largo debido y deben realizarse dentro de los 3 años :/

    OriginalEl autor

  3. 2

    Como una alternativa a la SAP/Sybase conductor, hemos desarrollado nuestro propio ADO.NET controlador de Núcleo para ASE:

    https://github.com/DataAction/AdoNetCore.AseClient

    .NET Core fue una tecnología clave para nosotros – en particular para AWS Lambda – y todavía no hay ninguna ADO.NET controlador de Núcleo disponible en SAP/Sybase.

    Nuestro controlador es compatible con la mayoría de SAP/Sybase ADO.NET características, tiene como objetivo ser una gota en el reemplazo para el SAP/Sybase una fácil transición, y apoya todas las .NET Frameworks usted le importa.

    Se puede obtener en Nuget:

    https://www.nuget.org/packages/AdoNetCore.AseClient

    OriginalEl autor

  4. 1

    Sybase 15 #ESD10 tiene soporte para ADO.NET 2.0, de acuerdo a este enlace en Sybase:
    http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc20155.1500/html/newfesd/CBHJAABF.htm


    Nuevas Características de Servidor Abierta 15.0 y el SDK 15.0 para Windows de Microsoft, Linux, UNIX y Mac OS X
    ADO.NET 2.0 de apoyo

    ASE ADO.NET Proveedor de Datos 2.0 se incluye con el SDK de liberación. El ADO.NET 2.0 soportados en esta versión son:

    *      Provider factories
    *      Provider statistics
    *      Bulk update
    *      Bulk copy
    *      Asynchronous commands
    *      Extended pooling support to clear pools
    *      Common base classes
    *      Database metadata
    

    Para obtener más información sobre las compatibles ADO.NET 2.0 características, vea Lo Nuevo en ADO.NET 2.0.

    OriginalEl autor

  5. 0

    De sybase sitio web:

    Sybase apoyo para ADO.NET, OLE DB y ODBC
    Adaptive Server versión 15.0 contiene nuevas ODBC y OLE DB para controladores desarrollado por Sybase. La tercera parte rebautizado con el nombre de OLE DB y ODBC Driver Kits incluye con las versiones anteriores ya no se entregan.

    Los jubilados Controlador ODBC equipo fue instalado en %SYBASE%\ODBC, y registrado con el Administrador de controladores ODBC como «Sybase ASE Controlador ODBC». El nuevo ASE Controlador ODBC de Sybase está instalado en %SYBASE%\DataAccess\ODBC, y registrado como «Adaptive Server Enterprise». La versión de envío con Adaptive Server y SDK es la versión 15.0 15.0.0.50.

    Los jubilados Controlador OLE DB equipo fue instalado en %SYBASE%\OLEDB, y utiliza el proveedor de nombre corto de «Sybase.ASEOLEDBProvider» y el largo nombre de «Sybase ASE Proveedor OLE DB». El nuevo ASE Proveedor OLE DB de Sybase está instalado en %SYBASE%\DataAccess\OLEDB, y los usos del proveedor nombre corto «ASEOLEDB». La versión de transporte con el SDK de 15.0 es la versión 15.0.0.51.

    Sybase recomienda que se inicie el proceso de migración a la nueva ODBC y OLE DB para controladores tan pronto como sea posible. Las nuevas características introducidas en Adaptive Server 15.0 sólo son compatibles con los nuevos drivers.

    Ver «Nuevas Características para OpenServer 15.0 y el SDK 15.0 para Windows, Linux y UNIX», para obtener instrucciones sobre cómo migrar a los nuevos controladores.

    Robert, su cita de sybase sitio web menciona odbc y oledb bits. Eso no es lo que estoy buscando. Estoy interesado en una ADO.net 2.0 de un proveedor. Gracias.
    usted puede utilizar el controlador ODBC con ADO.net 2.0.
    Tengo un código existente de la base que se conecta a Oracle y SQL Server mediante ADO.net 2.0 proveedores. Si puedo encontrar una Dasybase proveedor para ADO.net 2.0, puedo conectar en mi código existente con bastante facilidad. Si tengo que usar un controlador de ODBC y ADO ODBC bridge, que se traducirá en más de una reescritura. Así que usted puede ver que mientras que están a la derecha el controlador ODBC puede ser utilizado, no es lo que estoy buscando.
    Sí, pero ODBC no funciona correctamente en mono en Linux.

    OriginalEl autor

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea