Dulce de vainilla submódulo instalar de Alamofire, utilizando XCode6 y siguiendo las indicaciones para una T. Algo aquí simplemente no se ajuste a la derecha. El error que estoy consiguiendo es «no se Puede construir objective-c módulo «alamofire» en la importación de alamofire. Aquí está una captura de pantalla del error que estoy consiguiendo:

Swift. No podía construir objective-c, el módulo 'Alamofire'
Y mi configuración:

Swift. No podía construir objective-c, el módulo 'Alamofire'

  • Aquí está completo tutorial de vídeo -> youtube.com/watch?v=HJu0aIdJawk
  • stackoverflow.com/questions/26503389/…
  • creo que tienes que instalar alamofire según la instrucción dada aquí github.com/Alamofire/Alamofire
  • comenzaste a trabajar? funcionó para mí y después de otra «Build and run» y se detuvo y me dieron el mismo mensaje de error… 🙁
  • Un colega sólo tenía el mismo mensaje de error, pero la razón resultó ser que aún estaba usando Xcode 6.1 (es el 6.3 era en que nos encontramos, mientras escribo esto). Diciendo esto sólo para el registro, debe nadie lucha con la misma cosa.
InformationsquelleAutor stopshinal | 2014-11-09

10 Comentarios

  1. 88

    Cuando esto sucede, sólo construir los marcos de referencia por separado primero. En su caso:

    • Cambiar el esquema de Alamofire
    • Construir (⌘B)
    • Cambiar de nuevo a su esquema de
    • Ejecutar
    • Gran respuesta; yo era ajeno a la evolución de la acumulación esquema para corregir este tipo de errores!
    • Gracias por la ayuda.
    • Si usted tiene que construir el esquema por separado, probablemente significa que usted no tiene el marco establecido como una dependencia de destino en la configuración de compilación de la aplicación correctamente. Haga esto y usted no debería tener que crear manualmente.
    • He votado a favor de esto, ya que trabaja en Xcode. Por desgracia, no va a funcionar si la construcción de la línea de comandos o si el edificio para la Liberación.
    • Esto se ha corregido un problema que tuve con el GoogleApiClient/Unidad. Construir tendría éxito, pero tan pronto como se han realizado cambios en el archivo, Xcode se quejan acerca de la importación.
    • Impresionante! Gracias!

  2. 51

    Ir a Desarrollador/Xcode/DerivedData y eliminar la carpeta de su marco. (O simplemente eliminar DerivedData sí mismo)

    Si usted tiene una versión de que la aplicación en un simulador tendrás que eliminar la aplicación no.

    A continuación, Limpie & Construir

    • Esto funcionó para mí cuando se utiliza CocoaPods
    • Esto funcionó para mí también, pero luego me encuentro con varios comandos de producir, este enlace le ayudará a : stackoverflow.com/questions/50718018/….
  3. 28

    Esto siempre me funciona:

    1. Dejar De Xcode
    2. Eliminar ~/Library/Developer/Xcode/DerivedData
    3. Cambio en su marco del régimen y construir ⌘B
    4. Cambiar a la aplicación del régimen y construir ⌘B
    • esto no funcionó para mí,
    • Estoy usando «AWSS3» pod, y se obtiene el mismo error
  4. 21

    La eliminación de la DerivedData carpeta y la limpieza y la construcción del proyecto solucionado este problema para mí.

    • Esto no funcionó para mí,por favor ayuda
  5. 12

    Si usted está recibiendo este error al intentar importar un marco dinámico, asegúrese de que el marco está incluido en el destino del Destino de las Dependencias.

    Project > "Target" > Build Phases > Target Dependencies

    • También, si usted está trabajando con otro framework desarrollado en la misma área de trabajo, asegúrese de agregar el Proyecto como una biblioteca de enlace en lugar de en el marco de archivo, de lo contrario el marco no será visible como una dependencia de destino.
  6. 11

    Intente lo siguiente en este orden y uno de los pasos que se deben trabajar.

    1. Cmd+B – Construye el área de trabajo y debe, posiblemente, a construir el destino o el módulo que queremos.

    2. Cmd+K y, a continuación, Cmd+B – Limpiar y, a continuación, Construir

    3. Cmd+Cambio+Opción+K y Cmd+B – Limpiar la Carpeta de Compilación

    4. Dejar de Xcode, Eliminar los Datos obtenidos, el lanzamiento de Xcode y Cmd+Cambio+Opción+K entonces Cmd+B

    Este pasa a ser el más limpio posible manera de limpiar los datos derivados y otros cachés de Xcode.

    • Para aquellos con iCloud sync (Por ejemplo, tener el proyecto en la carpeta Documentos, por lo que sería sincronizar fácilmente a múltiples Mac), verifique que el archivo con nombre: XXX 2.swift. Buscar y eliminar a todos ellos, a continuación, ejecute pod install.
  7. 6

    Comentario fuera de la importación y de todo el código a través de ella, construir, ejecutar, a continuación, elimine. A mí me funcionó…

  8. 1

    He resuelto este problema en uno de mis Objective-C y Swift híbrido de proyectos.

    En su Objetivo-C puente de archivo, agregue la siguiente línea:

    #import <Alamofire/Alamofire.h>

  9. 0

    Cualquier vaina no se pudo construir puede causar este error. (en mi caso un viejo pod con obsoleta de la sintaxis no se pudo construir).

    Usted puede tratar de pod update para actualizar sus vainas a la última versión y ver cómo la cosa va.

    • Para aquellos con iCloud sync (Por ejemplo, tener el proyecto en la carpeta Documentos, por lo que sería sincronizar fácilmente a múltiples Mac), verifique que el archivo con nombre: XXX 2.swift. Buscar y eliminar a todos ellos, a continuación, ejecute pod install.

Dejar respuesta

Please enter your comment!
Please enter your name here