Podría alguien hacer esto por mí? Como sólo tengo mac y no puede probar es decir.

Lo que es una buena manera de ejecutar un evento SI el navegador es Internet Explorer, y la versión es menor de 10. Así que decir que es el IE 7, se mostrará el error, o si es IE 9.9, se mostrará el error, sin embargo si es IE 10, 10.1, 10.0.1 etc no se mostrará el error.

  • Googleando php detect browser no suba nada útil?
  • Soy consciente de que, a pesar de que no puedo probar mi código porque yo sólo posee macs. Estaba esperando que alguien podría hacer eso por mí.
  • regístrate gratis BrowserStack cuenta y usted puede probar en cualquier versión de IE: browserstack.com
  • gracias, esto va a ser útil.
InformationsquelleAutor Dylan Cross | 2012-02-19

3 Comentarios

  1. 2

    La función get_browser() puede ser utilizado para la detección de características.

    Si usted realmente quiere saber el navegador del usuario versión usted puede mirar en el $_SERVER[‘HTTP_USER_AGENT’].

    Una palabra de precaución: a pesar de que la mayoría de los usuarios no van a hacer esto, es posible enviar un diferente cadena de agente de usuario para el servidor que se puede hacer, por ejemplo, proteger la privacidad. Si alguien quiere ir tan lejos como el envío de un agente de usuario para poder utilizar su sitio web, aunque ellos probablemente saben cómo lidiar con los errores que puedan surgir.

    Como un lado de la cuestión, ¿cuál es la razón por la que usted está tratando de limitar su audiencia a IE 10 y hasta? ¿Por qué no utilizar una biblioteca como Modernizr para llenar las funciones que usted puede ser que falte en IE 9?

    EDITAR:
    Algo de información con respecto a la IE 10 cadena de agente de usuario. Usted va a querer leer que para saber qué coincidir con su $_SERVER[‘HTTP_USER_AGENT’] contra

Dejar respuesta

Please enter your comment!
Please enter your name here