Estoy trabajando en este proyecto donde tengo que conectar a la base de datos de Oracle. Estoy usando la última versión de WAMP 2.2 y también se activan todas las extensiones relacionadas con el Oráculo de extensiones de PHP. He utilizado los siguientes código para la conexión a la Base de datos de Oracle.

<?php 

$dbHost = "192.168.0.205";
$dbHostPort="1523";
$dbServiceName = "orcl";
$usr = "system";
$pswd = "admin";
$dbConnStr = "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)
        (HOST=".$dbHost.")(PORT=".$dbHostPort."))
        (CONNECT_DATA=(SERVICE_NAME=".$dbServiceName.")))";

if(!$dbConn = oci_connect($usr,$pswd,'192.168.0.205:1158/em')){
$err = oci_error();
trigger_error('Could not establish a connection: ' . $err['message'], E_USER_ERROR);
}
else
{
echo "COnnected";
}

$strSQL = "SELECT SYSDATE FROM DUAL";

$stmt = oci_parse($dbConn,$strSQL);
if ( ! oci_execute($stmt) ){
$err = oci_error($stmt);
trigger_error('Query failed: ' . $err['message'], E_USER_ERROR);
};

while(oci_fetch($stmt)){
$rslt = oci_result($stmt, 1); print "<h3>query returned: ".$rslt."</h3>";
}
?>

Sugerimos el error. Gracias de antemano.

  • compruebe phpinfo() a asegúrese de que las extensiones que realmente ESTÁN siendo cargados. usted puede haber modificado el mal .archivo ini (por ejemplo, versión de línea de comandos, que no afecta SAPI modo).
  • Gracias por su respuesta

1 Comentario

  1. 1

    La OCI8 extensión de PHP no está disponible en su instalación de PHP. Ver el manual de la OCI8 extensión de PHP para la instalación instrucciones.

    • Gracias por su respuesta. Buscando en link.
    • he instalado la extensión OCI8 y también se activan pero me sale este error.

Dejar respuesta

Please enter your comment!
Please enter your name here