Tengo ‘Servicio’ de la tabla y la columna de descripción de la siguiente

  1. Es Usuario de Verificación Necesarios para el servicio ?
  2. Es Usuario de Correo electrónico de Activación Necesario para el servicio ?
  3. Es Móvil del Usuario, requiere de la Activación para el servicio ?

Dudo en la nomenclatura de estas columnas de la siguiente

IsVerificationRequired
IsEmailActivationRequired
IsMobileActivationRequired

o

RequireVerification
RequireEmailActivation
RequireMobileActivation

Yo no puede determinarse de qué manera es la mejor .Así, Es uno de los mencionados nombre sugerido es el mejor o hay otros mejores ?

  • Creo que vale la pena mencionar que los nombres de columna como IsOwner no parecen tener una clara alternativa.
InformationsquelleAutor Amr Badawy | 2010-06-14

4 Comentarios

  1. 48

    Me gustaría (o no) el uso de «IsVerificationRequired»

    Intento añadir algo de sentido a mi los nombres de columna, así que es obvio (ValueDate, InsertedDateTime, IsActive, HazCheezBurger, ProductName etc). «Isxxxx» implica sí/no, por ejemplo, sin pensar y sólo tiene 2 estados a diferencia de «ProductName».

  2. 17

    Ejecutar con el Is variantes, o, al menos, de intercambio de la Require a Requires. Booleanos debe ser formulada como pregunta. Es decir, Puede, Tiene, Debe, todas son buenas prefijos para las funciones Booleanas/columnas. Ver Millón trescientos setenta mil ochocientos cuarenta para obtener más argumentos en esta

    • Esa es una pregunta interesante a la referencia porque es más acerca de la convención para la denominación de los métodos getter, no variables. Yo no sé acerca de otros idiomas, pero en Java, la convención siempre he visto que está utilizando el «es» como prefijo para los getter, pero NO la variable. Así, para una base de datos, usted está considerando un nombre de columna más como un campo o un getter? 😉
  3. 6

    Yo elegiría VerificationRequired, EmailActivationRequired etc.

    De la base de datos es la instantánea del estado, por lo que la anterior dijo que los nombres de columna va mejor en el que he mencionado en mi opinión.

    • Estoy de acuerdo. Los nombres de columna en la forma de una pregunta parecer excesiva. Sería como nomenclatura columnas FirstName y LastName «WhatIsTheFirstName» y «WhatIsTheLastName». Lo que es claramente tonto.
    • pero creo que, en algunos casos, como éste que necesitan, ya sea verdadero o falso pregunta es tan legible que determinar verdadero o falso no cualquier otro valor
    • No tonto. Usted también podría tener DateVerificationRequired ! A menudo me reemplazar campos Booleanos por los campos de fecha si que añade información extra (y, por supuesto, si el valor está sujeto a cambio). En ese caso un valor Nulo indica que la condición no se cumple (todavía).
  4. 1

    Me iría a por el uno que se adapte más a la sintaxis que se utiliza en el proyecto actual. Cualquiera es buena, ya que describe lo que la variable contiene, lo único que tendrá que preocuparse es de que mantener el mismo estándar de nomenclatura para todo el proyecto. Si aún no te decides cualquier estándar de nomenclatura para su proyecto, sin embargo, la primera sería la mejor ya que es lo que está más cerca de la de Java Bean estándar de nomenclatura, que es algo que muchos desarrolladores están acostumbrados.

Dejar respuesta

Please enter your comment!
Please enter your name here