Intento ejecutar apt-get install linux-headers-$(uname -r)
Pero me da un error.

E: Unable to locate package linux-headers-4.15.0-kali2-amd64
E: Couldnt find any package by glob 'linux-headers-4.15.0-kali2-amd64
E: Couldnt find any package by regex'linux-headers-4.15.0-kali2-amd64

Así que aquí está la cosa, yo cambio de la fuente.lista con (https://docs.kali.org/general-use/kali-linux-sources-list-repositories) estos repositorios(los enlaces).
Creo que mi versión de kali es no coincidir con los enlaces.
Cuando escribo apt-cache search linux-headers , mi encabezados parece como linux-headers-4.16.0-kali2-todos los…

Entonces, ¿hay alguna sugerencia? ¿Cómo puedo solucionar este problema ? O es que hay algún enlace para el 4.16.0 versión?

InformationsquelleAutor Caner Taşan | 2018-06-08

3 Comentarios

  1. 7

    Tuve el mismo problema con kali, y tengo trabajo, mediante la actualización de linux-image y linux-headers paquetes:

    apt-get update && apt-get upgrade
    apt-cache search linux-image
    

    a continuación, buscar última linux-image y linux-source paquetes con la misma versión. En mi caso la salida fue

    linux-headers-4.17.0-kali1-amd64 - Header files for Linux 4.17.0-kali1-amd64
    linux-headers-4.17.0-kali1-cloud-amd64 - Header files for Linux 4.17.0-kali1-cloud-amd64
    linux-image-4.17.0-kali1-amd64 - Linux 4.17 for 64-bit PCs
    linux-image-4.17.0-kali1-amd64-dbg - Debug symbols for linux-image-4.17.0-kali1-amd64
    ...
    

    entonces yo me acabo de instalar versiones más recientes:

    apt-get install linux-headers-4.17.0-kali1-amd64 linux-image-4.17.0-kali1-amd64 -y
    reboot
    
    • solucionado mi problema…. gracias! (debe ser aceptada respuesta)
  2. 1

    Fui capaz de actualizar a la última versión de kali (4.17.0) por la ejecución de este comando:

    sudo apt-get install --reinstall linux-image-4.17.0-kali3-amd64
    
  3. -2

    Primer lugar, trate de cambiar la línea

    linux-headers-4.15.0-kali2-amd64

    a

    linux-headers-4.15.0-kali-amd64

    Porque no hay kali2 cosa en absoluto.

    También lo que puedes hacer es ejecutar

    apt-cache search linux-headers
    

    Va a mostrar todas las opciones disponibles encabezados.

    • E: … (Estos son los errores ?) kali enviarme esas líneas como kali2? ¿Cómo puedo cambiar estas error kali2 a kali ? También puedo ejecutar apt-cache search linux-headers . Los resultados son linux-headers-4.16.0-kali2-todos los … (los que todos ellos 4.16.0) @delmys-asteroraena
    • A continuación, instale los encabezados de entonces. sudo apt-get install linux-headers-4.16.0-kali2-todos. Mi culpa en parte con kali2 lo siento.
    • No hay ningún enlace para 4.16.0-kali2-todos ( la última versión de estos enlaces son 4.15.0)

Dejar respuesta

Please enter your comment!
Please enter your name here