He estado tratando de utilizar eclipse RCP para crear una aplicación independiente y me sale el siguiente error cuando intento ejecutar la aplicación. Traté de mirar en soluciones anteriores, pero siento que me falta algo (o puede ser que no entiendo es lo suficientemente bueno)

`!SESSION 2014-01-22 14:58:27.824 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.osgi 4 0 2014-01-22 14:58:28.677
!MESSAGE Bundle org.eclipse.update.[email protected]:start not found.
!ENTRY org.eclipse.core.runtime 4 0 2014-01-22 14:58:28.792
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.core.runtime_3.9.0.v20130326-1255 [118]" could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.osgi 4 0 2014-01-22 14:58:28.798
!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.9.0.v20130326-1255.jar was not resolved.
!ENTRY org.eclipse.osgi 2 0 2014-01-22 14:58:28.818
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-01-22 14:58:28.819
!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.9.0.v20130326-1255.jar was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.819
!MESSAGE Missing required bundle org.eclipse.equinox.app_1.0.0.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.819
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.819
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.819
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.819
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.4.0,4.0.0).
!ENTRY org.eclipse.osgi 2 0 2014-01-22 14:58:28.825
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-01-22 14:58:28.825
!MESSAGE Bundle org.eclipse.core.runtime_3.9.0.v20130326-1255 [118] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.825
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.825
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.826
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.826
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.826
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.826
!MESSAGE Missing required bundle org.eclipse.equinox.app_1.0.0.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-01-22 14:58:28.826
!MESSAGE Missing dynamically imported package org.eclipse.core.internal.runtime.auth_0.0.0.
!ENTRY org.eclipse.osgi 4 0 2014-01-22 14:58:28.831
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
`

Mi Config.archivo ini se ve de la siguiente manera

    #Product Runtime Configuration File
eclipse.application=ZilliRCP.application
osgi.bundles.defaultStartLevel=4
eclipse.product=ZilliRCP.product
osgi.splashPath=platform:/base/plugins/ZilliRCP
osgi.bundles=ZilliRCP,\
ch.qos.logback.classic,\
ch.qos.logback.core,\
com.ibm.icu,\
javax.activation,\
javax.annotation,\
javax.inject,\
javax.mail,\
javax.servlet,\
javax.xml,\
org.eclipse.core.runtime,\
org.apache.batik.css,\
org.apache.batik.util,\
org.apache.batik.util.gui,\
org.apache.commons.lang,\
org.apache.lucene.analysis,\
org.apache.lucene.core,\
org.dbe.businessModeller-vetis,\
org.dbe.businessModeller-vetis-lib,\
org.eclipse.ant.core,\
org.eclipse.compare.core,\
org.eclipse.core.commands,\
org.eclipse.core.contenttype,\
org.eclipse.core.databinding,\
org.eclipse.core.databinding.observable,\
org.eclipse.core.databinding.property,\
org.eclipse.core.expressions,\
org.eclipse.core.filebuffers,\
org.eclipse.core.filesystem,\
org.eclipse.core.jobs,\
org.eclipse.core.net,\
org.eclipse.core.resources,\
org.eclipse.core.runtime,\
org.eclipse.core.variables,\
org.eclipse.e4.core.commands,\
org.eclipse.e4.core.contexts,\
org.eclipse.e4.core.di,\
org.eclipse.e4.core.di.extensions,\
org.eclipse.e4.core.services,\
org.eclipse.e4.ui.bindings,\
org.eclipse.e4.ui.css.core,\
org.eclipse.e4.ui.css.swt,\
org.eclipse.e4.ui.css.swt.theme,\
org.eclipse.e4.ui.di,\
org.eclipse.e4.ui.model.workbench,\
org.eclipse.e4.ui.services,\
org.eclipse.e4.ui.widgets,\
org.eclipse.e4.ui.workbench,\
org.eclipse.e4.ui.workbench.addons.swt,\
org.eclipse.e4.ui.workbench.renderers.swt,\
org.eclipse.e4.ui.workbench.swt,\
org.eclipse.e4.ui.workbench3,\
org.eclipse.emf,\
org.eclipse.emf.common,\
org.eclipse.emf.ecore,\
org.eclipse.emf.ecore.change,\
org.eclipse.emf.ecore.xmi,\
org.eclipse.equinox.app,\
org.eclipse.equinox.bidi,\
org.eclipse.equinox.common,\
org.eclipse.equinox.ds,\
org.eclipse.equinox.event,\
org.eclipse.equinox.http.jetty,\
org.eclipse.equinox.http.servlet,\
org.eclipse.equinox.p2.core,\
org.eclipse.equinox.p2.engine,\
org.eclipse.equinox.p2.metadata,\
org.eclipse.equinox.p2.metadata.repository,\
org.eclipse.equinox.p2.repository,\
org.eclipse.equinox.preferences,\
org.eclipse.equinox.registry,\
org.eclipse.equinox.security,\
org.eclipse.equinox.util,\
org.eclipse.help,\
org.eclipse.help.base,\
org.eclipse.jetty.continuation,\
org.eclipse.jetty.http,\
org.eclipse.jetty.io,\
org.eclipse.jetty.security,\
org.eclipse.jetty.server,\
org.eclipse.jetty.servlet,\
org.eclipse.jetty.util,\
org.eclipse.jface,\
org.eclipse.jface.databinding,\
org.eclipse.jface.text,\
org.eclipse.net4j.jms.api,\
org.eclipse.osgi.services,\
org.eclipse.swt,\
org.eclipse.text,\
org.eclipse.ui,\
org.eclipse.ui.editors,\
org.eclipse.ui.forms,\
org.eclipse.ui.ide,\
org.eclipse.ui.ide.application,\
org.eclipse.ui.ide.application.source,\
org.eclipse.ui.ide.source,\
org.eclipse.ui.intro,\
org.eclipse.ui.views,\
org.eclipse.ui.workbench,\
org.eclipse.ui.workbench.texteditor,\
org.eclipse.xsd,\
org.slf4j.api,\
org.w3c.css.sac,\
org.w3c.dom.smil,\
org.w3c.dom.svg,\
ch.qos.logback.slf4j,\
javax.transaction,\
org.eclipse.core.filesystem.win32.x86,\
org.eclipse.core.net.win32.x86,\
org.eclipse.core.resources.win32.x86,\
org.eclipse.core.runtime.compatibility.registry,\
org.eclipse.equinox.security.win32.x86,\
org.eclipse.equinox.transforms.hook,\
org.eclipse.equinox.weaving.hook,\
org.eclipse.objectteams.otequinox.hook,\
org.eclipse.swt.win32.win32.x86,\
org.eclipse.ui.win32
osgi.splashPath = platform:/base/plugins/org.eclipse.platform  
<configurations> 
<plugin id="org.eclipse.core.runtime" autoStart="true" startLevel="4" /> 
</configurations> 
osgi.bundles=org.eclipse.equinox.transforms.[email protected],org.eclipse.equinox.[email protected]:start,org.eclipse.update.[email protected]:start,org.eclipse.core.[email protected]
  • Se que la generación de este mediante un xxx.product archivo o de alguna otra manera?
  • Estoy tratando de generar mediante el xxx.producto. Estoy tratando de modelo de este plugin (sourceforge.net/projects/sbeaver/files) como una aplicación independiente mediante PCR. Hasta ahora, mucha suerte :(.
InformationsquelleAutor Betafish | 2014-01-22

1 Comentario

  1. 1

    Si usted está usando un .product archivo introduzca el plugin de las dependencias en las Dependencies ficha del producto editor. Uso Generate a default config.ini archivo en el Configuration ficha. Esto es mucho más fácil que intentar escribir los archivos de configuración de ti mismo.

Dejar respuesta

Please enter your comment!
Please enter your name here