He buscado mucho pero realmente no puedo encontrar un post que ayuda a que yo soy un poco nuevo en android por lo que algunos de esto va por encima de mi cabeza. De todos modos, mis problemas comenzaron cuando tengo un error diciendo que el plugin de gradle era viejo y la sincronización no sería completa. Así que he cambiado un par de cosas a su alrededor, no muy seguro de lo que hice. Ahora tengo:

De Error(25,13) no pudo resolver: com.android.apoyo:appcompat-v7 24.0.1

Proyecto gradle archivo:

    //Top-level build file where you can add configuration options common to     all sub-projects/modules.

    buildscript {
        repositories {
            jcenter()
        }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.3'

        //NOTE: Do not place your application dependencies here; they belong
        //in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

aplicación gradle archivo:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 24
    buildToolsVersion "24.0.1"
    defaultConfig {
        applicationId "com.bisesifreelance.maxbisesi.tic_tac_toe"
        minSdkVersion 23
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:24.0.1'
    testCompile 'junit:junit:4.12'
}

También he instalado todas las herramientas de construcción en el SDK manager no puedo incrustar imágenes? pero dice:

Android SDK de la Plataforma-Herramientas 24.03 instalado

Android SDK Tools 25.2.2 instalado

Gracias! Estoy muy perdido.

no te olvides de ejecutar las actualizaciones de android studio para obtener la API para 24 V
podría resolver su problema? se han de obtener el mismo error
pisguy si no recuerdo mal Tiagos solución que finalmente me ayudó a encontrar mi error
se puede comprobar que la solución también si u todavía tiene ese problema, stackoverflow.com/questions/49140950/…

OriginalEl autor SallyRothroat | 2016-09-15

9 Comentarios

  1. 14

    intentar

      compile 'com.android.support:appcompat-v7:24.2.1'

    EDITAR

    Para el sdk de 27

    buildToolsVersion "27.0.3"
    
    compile "com.android.support:appcompat-v7:27.1.1"
    Me estoy poniendo Error:Could not find com.android.support:appcompat-v7:25.0.1. Alguna idea de por qué?

    OriginalEl autor Tiago Oliveira

  2. 16

    También se puede escribir así:

    allprojects {
            repositories {
                jcenter()
                maven {
                    url "https://maven.google.com"
                }
            }
        }

    OriginalEl autor VolodymyrH

  3. 7

    Asegúrese de que existe esta carpeta:

    \your-android-sdk\extras\android\m2repository\com\android\support\appcompat-v74.0.1

    De curso, 24.0.1 debe ser reemplazado por la versión más reciente.

    He tenido este problema, porque de vez en cuando cambió de nombre 24.0.1 a otra cosa, y por lo que la carpeta no se pudo encontrar.

    OriginalEl autor activity

  4. 6

    Trate de añadir jcenter como de esta manera

    repositories {
        jcenter {
            url "http://jcenter.bintray.com/"
        }
    }

    Lugar de

      repositories {
            jcenter()
        }

    OriginalEl autor Mithun Sarker Shuvro

  5. 3

    Tuve el mismo problema después de la actualización de Android Studio. En mi caso era un problema de permisos como puedo hacer que mi día-a-día de programación en mi cuenta de usuario, mientras que Android studio fue instalado y actualizado con la cuenta de administrador.

    REVISIÓN:

    Abrir el independiente SDK manager y vaya a ‘herramientas’. Haga clic en «Soporte para Android del Repositorio’ (que probablemente conjunto como «No instalado») y la instalación de los paquetes. Si aparece un mensaje de error diciendo algo como ‘error al intentar cambiar el nombre de la carpeta’. Vaya a la carpeta que se menciona en el mensaje y asegúrese de que los permisos están configurados correctamente. Después de que haga clic en ‘Intente otra vez’ y se debe instalar el paquete sin problema.

    NOTA: Esto puede ocurrir un par de veces más. Sólo tiene que repetir el proceso para cada archivo. El problema entonces debe ser resuelto.

    esto funcionó para mí.

    OriginalEl autor Kesupile K

  6. 1

    Cambiar un carácter - a :

    compile 'com.android.support:appcompat-v7:24.2.1'

    lugar de

    compile 'com.android.support:appcompat-v7-24.2.1'

    OriginalEl autor bilal arikan

  7. 0

    a intentar actualizar el IDE y quitar la anterior versión de compilación (23) después de instalar más tarde uno y cambiarle el nombre a una nueva.

    OriginalEl autor Harshit Srivastava

  8. 0

    Abrir el SDK Manager y actualización de los Extras–>Soporte para Android del Repositorio.

    Camino ..sdk\extras\android\m2repository\com\android\support\appcompat-v7>

    De verificación para la actualización de la versión instalada.

    OriginalEl autor Chinmoy

Dejar respuesta

Please enter your comment!
Please enter your name here