Estoy usando Android Studio 3.1.4. Desde que me gustaría hacer un Diseño de la Ficha, yo agregue el código implmentation 'com.android.support design:28.0.0-rc02', que tiene la misma versión que support.accompat en construir.gradle pero aparece el error.

Puedo saber que pasa? ¿Cómo puedo solucionar el problema?

Gracias por su ayuda.

Mi código
no pudo resolver: android.apoyo.diseño:28.0.0-rc02

Mensaje de Error
no pudo resolver: android.apoyo.diseño:28.0.0-rc02

  • No está en el repositorio de google sin embargo Google Maven
InformationsquelleAutor Kitty Li | 2018-09-01

5 Comentarios

  1. 10

    Tuve el mismo problema y lo solucionó, tan solo cambiando la versión de que todo 28.0.0-rc01.

  2. 2

    Ediciones

    design:28.0.0-rc02 se publica ahora, simplemente añadir y volver a construir.


    Antes de ediciones

    Así que todo lo que puede hacer por ahora es usar la versión anterior, por appcompat y espere hasta que el diseño de la biblioteca nueva versión 28.0.0-rc02 liberación.

    Así que por ahora uso este :

    implementation 'com.android.support:appcompat-v7:28.0.0-rc01'.
    

    No sé por qué… Pero ellos(sdk a los desarrolladores) que se comportan como Microsoft..

    «Ohh..compila, permite enviar».

    Que acaba de lanzar y que no les importa acerca de los errores.. después de actualizar a la última libs cada vez, lo primero que me sale es..

    «Layout editor de vista previa de errores.»

    espero que será más fácil la próxima vez. :/

  3. 1

    com.android.apoyo:diseño:28.0.0-rc02 debe ser reemplazado por el no pudo resolver: com.android.apoyo:diseño:28.0.0-rc01

    Creo que no hay ningún rc02 existen en Android Studio, porque cada vez que sincronice el proyecto de la
    error, todavía se producen.
    Después de reemplazar el rc02 a rc01 el proyecto funciona bien.

    dependencies {
        implementation fileTree(include: ['*.jar'], dir: 'libs')
        implementation 'com.android.support:appcompat-v7:28.0.0-rc01'
        implementation 'com.android.support.constraint:constraint-layout:1.1.2'
        testImplementation 'junit:junit:4.12'
        androidTestImplementation 'com.android.support.test:runner:1.0.2'
        androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
        implementation 'com.android.support:recyclerview-v7:28.0.0-rc01'
        implementation 'com.android.support:design:28.0.0-rc01'
    }
    
    • Miré a mi alrededor en Google repositorio de Maven. 28.0.0-rc02 está ahí, pero por alguna razón el componente de diseño, específicamente, es falta.
    • Estoy de acuerdo en que hay algunas lagunas en rc02. Supongo que podemos esperar para más actualizaciones en esta versión.
  4. 0

    Hoy he actualizado mi SDK y el mismo problema ocurrió. para mí por cambiar mi estas dos versiones de la biblioteca, el problema fue solucionado:

    =>construir.gradle(Módulo:aplicación):

    implementation 'com.android.support:appcompat-v7:28.0.0-rc02'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    

    cambiado a:

    implementation 'com.android.support:appcompat-v7:28.0.0-rc01'
    implementation 'com.android.support.constraint:constraint-layout:1.1.2'
    

Dejar respuesta

Please enter your comment!
Please enter your name here