Estoy creando una aplicación para Android en Android Studio. Cuando abro el editor de diseño, veo que el gris «ventana emergente» en la parte superior de la presentación, que dice que

No podía resolver los recursos de @style/Widget.Holo.La luz.ActionMode.De forma inversa.

Esto sucede cuando cambio la «representación de la versión» a API 15 (Android 4.0.3).
Funcionó hace un minuto, pero cuando me vuelva a conectar el diseño, acabo de recibir este error.

Edición: yo uso el AppCompat biblioteca.
El tema es definido como este

<style name="AppTheme" parent="Base.Theme.AppCompat.Light.DarkActionBar" />

La aplicación funciona bien, cuando lo ejecuto, pero no se muestra correctamente (al menos que me da el error en el editor.

Yo estaría encantado si alguien me pudiera ayudar con esto. Gracias!

¿Estás usando el appcompat de la biblioteca?
Sí, lo sé. Ver la versión actualizada de la pregunta.
aquí está el tema code.google.com/p/android/issues/detail?id=163572 en mi caso no tomo android:gravity=»left» para el Dispositivo que ejecuta la API de 14 !!! sorprendentemente android:gravity=»izquierda|derecha» funciona!

OriginalEl autor Daniel Kvist | 2015-02-27

3 Comentarios

  1. 16

    Este problema me ocurrió cuando la actualización de Android Studio para la versión 1.1.0 y la apertura de un proyecto existente, sin cambiar nada.

    Para mí, sólo cambiando la vista previa de la representación de la API a los 19 o anterior hace que el mensaje desaparezca.

    Exactamente! Lo hizo comenzar a aparecer cuando he actualizado Android Studio. Funciona cambiando el render de la versión. Ya he probado eso. Yo estaba pensando en una manera de descargar/encontrar la falta de recursos o algo parecido, pero voy a marcar esto como correcto. Gracias!
    Esto parece más a una solución, no una solución real!

    OriginalEl autor futu

  2. 10

    Hola, he enfrentado el mismo problema y la solución que encontré fue En el android studio Abrir la Seleccionar Tema de Diálogo y bajo la Todos categoría seleccione NoTitleBar.OverlayActionModes y pulse aceptar.
    El problema estaría resuelto. Pero puede mostrar en un tema oscuro.

    Lamentablemente, esto no funciona para mí, sin embargo, la vista previa en realidad no importa. Yo sólo lo uso para la posición de los componentes, a continuación, pruebe el resto en mi teléfono. Gracias de todos modos!
    Su bienvenida.! Trabajó para mi aplicación, aunque. Pero sí no importa si su trabajo en el dispositivo.

    OriginalEl autor amanpurohit

  3. 0

    Hacer el proyecto a Nivel de API más reciente.

    Para mí,el problema se produjo cuando mi build.gradle contenido como este:

    compileSdkVersion 16
    buildToolsVersion "23.0.2"
    
    defaultConfig {
        applicationId "com.xiaoguang.xx"
        minSdkVersion 16
        targetSdkVersion 16
        versionCode 1
        versionName "1.0"
    }

    Después de la descarga del sdk de 19 y cambio build.gradle, el problema se ha solucionado.

    compileSdkVersion 19
    buildToolsVersion "19.1.0"
    
    defaultConfig {
        applicationId "com.xiaoguang.xx"
        minSdkVersion 19
        targetSdkVersion 19
        versionCode 1
        versionName "1.0"
    }

    cambio de la vista previa de api

    Este «soluciona» el problema haciendo que su proyecto no trabajar con el SDK de la versión 16.

    OriginalEl autor YuGuang Han

Dejar respuesta

Please enter your comment!
Please enter your name here