Añadido QT += svg y traté de sólo QT += svg y mayorque(QT_MAJOR_VERSION, 4): QT += svg para el .pro de la solución de archivo y corrió qmake desde el interior de la QtCreator y tengo este error:

de error: módulo Desconocido(s) en QT: svg

Alguna idea?

  • Ubuntu 13.10. Cómo comprobar esto?
InformationsquelleAutor user3191398 | 2014-01-13

2 Comentarios

  1. 65

    Te falta la instalación de la QtSvg de la biblioteca. Intente instalar en tu Ubuntu 13.10 de la siguiente manera:

    sudo apt-get install libqt5svg5*
    • curiosamente no he visto el dev paquetes en synaptic cuando entré qt svg
    • En Fedora es sudo dnf install qt5-qtsvg-devel.
    • Sólo haciendo sudo apt-get install libqt5svg5-dev resuelve todas las dependencias necesarias por pgModeler.
    • Esto en Ubuntu 16.04
    • cómo instalar el módulo de una forma estática construida versión de Qt en Windows (ver mi post aquí stackoverflow.com/questions/54097920/…)
  2. 2

    Debian Tramo:

    sudo apt install libqt5svg5-dev

    Fedora (cortesía de @robin-verde):

    sudo dnf install qt5-qtsvg-devel

Dejar respuesta

Please enter your comment!
Please enter your name here