Maven para Eclipse 1.5.0 plugin puede ser instalado en Kepler

He descargado Eclipse Kepler y trató de instalar M2Eclipse de su actualización de sitio.

Después de seleccionar Integración de Maven para Eclipse, hice click en Siguiente y obtuve el siguiente error:

Alguno de los requisitos: Integración de Maven para Eclipse 1.5.0.20140606-0033 (org.eclipse.m2e.núcleo 1.5.0.20140606-0033) requiere » paquete com.google.la guayaba [14.0.1,16.0.0)’, pero no se pudo encontrar

Así que he buscado a través de la internet para averiguar cómo instalar la Guayaba el plugin de Eclipse. Algunos dicen que es desde el Eclipse marketplace, pero no se puede descargar. He descargado el binario y tratado de copiarlo al directorio de plugins de Eclipse. Sigue siendo el mismo resultado.

cp ~/Downloads/guava-16.0.1.jar /Applications/eclipse/plugins/com.google.guava_16.0.1.v1234.jar

¿Cómo puedo instalar la m2e plugin para Kepler?

InformationsquelleAutor Howy | 2014-06-29

6 Kommentare

  1. 83

    m2e 1.5.0 requiere Eclipse de Luna. No funciona con los de Kepler o Índigo. (gracias a @HDave para el enlace)

    Así que hay que utilizar una versión anterior de m2e en virtud de Kepler.

    Durante la instalación, , desactive la opción «Mostrar sólo las últimas versiones de software disponibles». A continuación, sólo comprobar la 1.4.1 versión o una versión más baja en la lista de candidatos. No requiere de la Guayaba de la dependencia.

    • sudo eclipse para la instalación / actualización de materias hizo el truco para mí (mi primer intento para instalar 1.4.1 o 1.4.0 llevó a la ruptura de la mayoría de los de mi eclipse componentes…)
    • En realidad, no es cierto. Enlace por @HDave dice que m2e 1.5.0 es incompatible con 3.7/Indigo. No hay nada acerca de Kepler no. Y de hecho, con la guayaba instalado desde Órbita, yo era capaz de actualizar m2e en Kepler SR2 a 1.5.0.
    • Esta respuesta es incorrecta, eclipse.org/m2e/documentation/release-notes-15.html estados que m2e 1.5 es «compatible con Eclipse Kepler y de la Luna»
  2. 25

    Asegúrese de que tiene la Luna repositorio en «Sitios de Software Disponibles».

    Usted puede agregar en:- > Instalar Nuevo Software.
    A continuación, en el «Trabajar con» de entrada, escriba http://download.eclipse.org/releases/luna/ y presione entrar.

    Después de eso, usted debería ser capaz de instalar m2e con http://download.eclipse.org/technology/m2e/releases/

    • Muchas gracias! Estaba buscando esto desde el pasado 2 días. Esto funcionó para mí como un encanto!
    • Eso no funciona para mí, después de instalar todas las bibliotecas de la Luna, mi Eclipse no se puede iniciar. La carga de Eclipse cada vez que falla, tengo que desinstalar eclipse y volver a instalar todo de nuevo.
    • A mí me funciona. Usted no necesita instalar nada desde la luna el sitio de actualización de @Howy sólo agregarlo a la obra con la lista en orden a m2 1.5 instalación de la funda no lo necesita
    • Yo estaba usando Luna y recibiendo el mensaje de error descrito, pero poniendo en el primer enlace que usted haya proporcionado y selección de m2e 1.5 a partir de allí funcionó a la perfección. Gracias.
    • Muchas gracias. Como la Luna aún no se ejecutan correctamente en Kubuntu (famoso oxygen-gtk-error), esto ayuda mucho, mientras que todavía el uso de Kepler y a pesar de ser capaz de trabajar con java 8 y lo que viene.
  3. 9

    Puede encontrar Guayaba 15 en Órbita proyecto – «repositorio de versiones en paquete de bibliotecas de terceros que están aprobados para su uso en uno o más de los proyectos de Eclipse». También se puede añadir directamente a la La órbita del proyecto de actualización del sitio a su kepler de la instalación y usted será capaz de actualizar m2e

    • La adición de la Órbita del proyecto de actualización del sitio resuelto para mí. Acaba de agregar y traté de instalar m2e de mercado nuevo y no tiene errores. Estoy usando Juno 4.2.2 . Gracias por esta respuesta
    • Wow! Fantástico encontrar! Acabo de instalar m2e 1.5 en Juno así, y no hay errores en la instalación. Sería estupendo si pudiéramos encontrar otro lugar para agregar esta (como un FAQ o algo).
  4. 2

    Lo que me ha ayudado para Juno liberación es la adición de http://download.eclipse.org/technology/m2e/releases/1.3/ como plugin de actualización del sitio. La versión de Maven para Eclipse fue de 1,3 en lugar de 1.5, pero, para mí, esta diferencia entre fue menor principal de la ausencia de extra dependencias y extra actualización de los sitios, especialmente de la más reciente versión del IDE de sí mismo.

    ¿Necesariamente necesita la versión 1.5 o 1.3 también debe ser bueno?

    • Gracias Michael. El mencionado URL puede trabajar correctamente.
  5. 2

    PASOS PARA INSTALAR MAVEN (en Eclipse):

    Maven plugin de Eclipse para la instalación paso por paso:

    • Abrir Eclipse IDE

    • Haga clic en Ayuda -> Instalar Nuevo Software…

    • Desactive la opción «Mostrar sólo las últimas versiones de software disponibles»

    • Clic en el botón Añadir en la esquina superior derecha

    • En pop-up: llenar el Nombre como «M2Eclipse» y la Ubicación como»http://download.eclipse.org/technology/m2e/releases«

    • Marque sólo una Versión 1.4.1.

    • Ahora haga clic en ACEPTAR Después de que la instalación se habría iniciado.

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea