Estoy ocupado tratando de conseguir el MapView incluido en mi proyecto Android. Estoy siguiendo el MapView tutorial en el sitio web para desarrolladores de Android, pero estoy recibiendo un error:

'MapActivity cannot be resolved to a type'

He probado a pulsar Ctrl+Mayús+O a la importación automática de todas las clases, pero no está ayudando. Cuando trato de incluir los Mapas de la biblioteca manualmente da este error:

'The import com.google.android cannot be resolved'

He añadido la siguiente línea (ver más abajo) para el Manifiesto y mi destino es la API de 7 (Plataforma: 2.1).

<uses-library android:name="com.google.android.maps" />

¿Qué estoy haciendo mal?

Gracias!!!

¿Tienes tus proyectos de construir el conjunto blanco a la API de Google?
Gracias por tu comentario. He usado el Android SDK Manager para obtener todos los paquetes. He instalado todos los paquetes disponibles y después de todo el API de Google construir de destino no está en la lista? Tengo todos los paquetes de Android (1.5 hasta 4.0).
Usted está utilizando eclipse, ¿correcto? Trate de ir a la Ventana>SDK de Android ADK Manager>los Paquetes Instalados, a continuación, asegúrese de que estén al día.
He instalado todos los paquetes y todos ellos están al día, pero el API de Google todavía es no subir.

OriginalEl autor Jesper Veldhuizen | 2011-11-15

2 Comentarios

  1. 5

    De la API de Google es una tercera parte del SDK. Elegir tercero en paquetes de administrador.

    Gracias por tu comentario. He abierto el SDK manager de nuevo, pero no puedo ver ninguna tercera parte del SDK? Ver esta imagen: img249.imageshack.nosotros/img249/1340/sdk.png
    Intente seleccionar Ordenar por: Repositorio. Si Usted todavía no puede ver: Herramientas->Administrar Ad-sobre los Sitios y agregar dl-ssl.google.com/android/repository/addon.xml
    Muchas gracias, tengo la Api de Google ahora en mi lista de paquetes!! Tuve que agregar un nuevo anuncio.

    OriginalEl autor TheJohnny

  2. 9

    Usted necesita para hacer referencia correcta de la biblioteca en tiempo de compilación. Pero lo que usted describe es pedir Android para el uso específico de la biblioteca en tiempo de ejecución.

    Que usted necesita a la derecha haga clic en su proyecto de Eclipse, Propiedades -> Android. En la generación del Proyecto de Destino seleccione cualquier destino con el proveedor de Google Inc..

    OriginalEl autor Mohit

Dejar respuesta

Please enter your comment!
Please enter your name here