Digamos que tengo una lista de valores y ya he fragmentada en grupos para hacer un histograma.

Desde Excel no tiene histogramas, he hecho un gráfico de barras usando los grupos que he desarrollado. En concreto, en las frecuencias 2 6 12 10 2 y se produce el gráfico de barras que aparece a continuación.

Siguiente, quiero añadir una distribución normal (línea de parcela), con una media de 0.136 y la desviación estándar de 0.497 en la parte superior de este histograma. ¿Cómo puedo hacer esto en excel? Necesito el eje de la línea de tal manera que se toma el ancho de la barra de la parcela. De lo contrario, se puede conseguir algo como que he adjuntado.

Pero…la normal debe ser mostrados en el gráfico de barras. ¿Cómo puedo lograr este efecto?

Mac Excel 2011 - Histograma con la distribución normal

InformationsquelleAutor CodeGuy | 2012-07-18

1 Comentario

  1. 5

    Hay dos parte principal de esta respuesta:

    Primer lugar, he de ingeniería inversa de los datos agrupados para venir para arriba con una media y desviación estándar apropiadas en esta escala.

    Segundo, yo usé algunas gráfico de artimañas para hacer que la curva de distribución normal mirar a la derecha cuando se superponen en el gráfico de columnas. He utilizado Excel 2007 para esto; esperamos que tengan las mismas opciones que están disponibles en su versión.


    Parte 1: Ingeniería Inversa

    Mac Excel 2011 - Histograma con la distribución normal

    La columna B, las fórmulas son:

    Último Punto =MAX(A2:A6)

    Significa =SUMPRODUCT(B2:B6 A2:A6)/SUMA(B2:B6)

    E(x^2f) =SUMPRODUCT(A2:A6^2,B2:B6)

    E(xf)^2 =SUMPRODUCT(A2:A6; B2:B6)^2

    E(f) =SUMA(B2:B6)

    Varianza =B10-B11/B12

    Desvest =SQRT(B13/(B12-1))

    Parte 2: Gráfico De Engaño

    Tabla de datos:

    Column D es sólo un contador incremental. Este será el número de puntos de datos en la curva de distribución normal.

    E2 =D2/$B$8 etc.

    F2 =NORMDIST(E2,$B$9,$B$14,FALSE) etc.

    Gráfico:

    Ahora, agregar Columnas E:F a la carta. Usted necesitará masaje un par de cosas:

    • Cambiar la serie de un gráfico X-Y. Esto puede requerir algo de edición de la tabla de la serie a la fuerza de una sola serie para su uso deseado valores de X e y.
    • Cambio de la serie para el uso de la secundaria de los ejes (X e y).
    • Cambiar la secundaria eje X rango de 0.5-5.5 (es decir, 0,5 en ambos lados de la columna a la tabla de valores de la categoría). De esta forma, alinee la primaria y secundaria ejes-X.
    • Cambiar el eje Y secundario rango de 0-1
    • Formato de los X-Y aparición de serie al gusto (yo sugiero extracción de valor de los marcadores).

    El resultado hasta ahora:

    Mac Excel 2011 - Histograma con la distribución normal

    Por último, puede quitar las marcas y etiquetas en los ejes secundarios para limpiar la mirada.

    Posdata: Gracias a Juan Peltier para innumerables gráficos inspiraciones a través de los años.

Dejar respuesta

Please enter your comment!
Please enter your name here