Una pregunta rápida estoy esperando que alguien me puede ayudar con.

En firefox nuestro slider jQuery funciona a la perfección, sin embargo en la visualización con internet explorer hay algunos errores de javascript que se produzcan. El sitio web es http://foscam-uk.com/index.php

Con la esperanza de que hay una posible solución a esto.

Saludos y Gracias!

Errores:
La página web con los detalles del error

User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; PC Media Center 6.0; .NET4.0C; .NET4.0E; InfoPath.3)
Marca de hora: Miércoles, 6 Jun 2012 22:36:43 UTC

Mensaje: el Objeto no admite esta propiedad o método
Línea: 5653
Char: 9
Código: 0
URI: http://foscam-uk.com/js/prototype/prototype.js

Mensaje: el Objeto no admite esta propiedad o método
Línea: 5988
Char: 5
Código: 0
URI: http://foscam-uk.com/js/prototype/prototype.js

Mensaje: el Objeto no admite esta propiedad o método
Línea: 2
Char: 5
Código: 0
URI: http://foscam-uk.com/skin/frontend/default/theme316/js/scripts.js

Mensaje: el Objeto no admite esta propiedad o método
Línea: 5736
Char: 7
Código: 0
URI: http://foscam-uk.com/js/prototype/prototype.js

Mensaje: el Objeto no admite esta propiedad o método
Línea: 5988
Char: 5
Código: 0
URI: http://foscam-uk.com/js/prototype/prototype.js

Mensaje: el Objeto no admite esta propiedad o método
Línea: 73
Char: 11
Código: 0
URI: http://foscam-uk.com/index.php

  • Que havascript están produciendo errores?
  • También estoy enfrentando el mismo problema y las respuestas no son de ayuda.
InformationsquelleAutor user994319 | 2012-06-06

4 Comentarios

  1. 2

    Es decir, tiene algunas limitaciones en cuanto al número de archivos CSS y JS. (Alrededor de 30). Yo no los cuentan, pero parece que tienen un montón de JS y css referencias de archivos. Si se supera este es decir, básicamente, dejar de descargar el script o archivo css. Puede comprobar mediante el uso de Fiddler.

    Intentar compactar a un archivo único con herramientas compresor (ex: http://developer.yahoo.com/yui/compressor/ )

    • Hmm, no había pensado en esto. Voy a intentar hacer sugerido y post atrás. Saludos para la ayuda.
    • He comprimido de ellos, todavía no hay alegría.
  2. 1

    prototype.js parece estar arrojando errores en cada navegador, pero estos parecen no tener efecto en su sitio.

    su sitio funciona bien en IE7 y IE10. En IE8, la versión de jQuery lanza un error, no el control deslizante de código. Me gustaría actualizar su 1.7.1 versión de jQuery para 1.7.2 (la última).

    • Hola, gracias por la respuesta. He actualizado a la 1.7.2 y todavía no se muestran en IE8, ¿hay alguna manera de poder arreglar esto? Gracias por ayudar.
  3. 1

    Por lo que parece que va a cargar varias bibliotecas de terceros. Carga de PrototypeJS, Scriptaculous, jQuery y jQuery plugins*. Me parece que lo que tienes no es tanto un JavaScript problema como un plugin problema de la organización.

    Ahora, que parecen estar usando cosas como jQuery.noConflict() en un solo lugar, pero no en otro.

    Mi sugerencia es desactivar todos los módulos actuales que se está utilizando en el sitio que inyectar JavaScript, y luego volver a activar uno a la vez. Cada vez que se vuelva a habilitar un plugin, comprobar para ver si ese, y todos los otros plugins también están trabajando.


    *De hecho, va a cargar más de un par de bibliotecas. En realidad estás carga dos versiones de jQuery, además de Prototipo. Esta no es una buena práctica. Aquí es lo que puedo ver, sin contar el de Magento genera código que se inserta:

    • Prototipo 1.7
    • Validación De Tarjetas De Crédito Con Javascript
    • Realmente fácil de validación de campo con el Prototipo
    • secuencia de comandos.aculo.nosotros builder.js
    • secuencia de comandos.aculo.nosotros effects.js
    • secuencia de comandos.aculo.nosotros controls.js
    • secuencia de comandos.aculo.nosotros slider.js
    • jQuery 1.4.2
    • jCarouselLite
    • jQuery 1.7.1
    • TMSlider: basado en jQuery image slider
    • jQuery Easing v1.3

    Usted necesita para hacer un replanteamiento de cómo se está manejando algunos de estos efectos. Hay una gran cantidad de superposición en lo que estos libs hacer, y que sería mejor que ver si hay una manera de crear un poco de cordura en la cual los módulos que está eligiendo.

  4. 0

    Tuve un problema similar con mi script del lado del cliente. El IE10 F12 Dev herramientas de secuencia de comandos de la ficha mostraron errores en la sintaxis de jQuery aunque el sitio trabajó en IE8 y IE9.

    Una de las bibliotecas que he usado (Telerik Kendo UI) no fue IE10 compatible todavía.

    Para la fuerza de IE10 para mostrar la página, he tenido que añadir esta etiqueta meta a la parte superior (primer elemento en la cabeza), de mi CABEZA etiqueta:

     <meta http-equiv="X-UA-Compatible" content="IE=9" />

    A continuación, las páginas trabajó de nuevo.

Dejar respuesta

Please enter your comment!
Please enter your name here