Estoy recibiendo errores cuando intento hacer un «yum update» que estoy seguro de cómo resolver. A continuación es el mensaje de error:

--> Finished Dependency Resolution
Error: Package: nginx-1.4.7-1.el6.ngx.x86_64 (nginx)
           Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)

Cuando intento actualizar (que creo que es el mejor paso adelante, que estos mí no hay «nada que hacer», usando la siguiente línea:

como:

sudo yum reinstall openssl

o:

sudo yum install http://mirror.centos.org/centos/6/os/x86_64/Packages/openssl-1.0.1e-15.el6.x86_64.rpm

Examining /var/tmp/yum-root-qbBKfF/openssl-1.0.1e-15.el6.x86_64.rpm: openssl-1.0.1e-15.el6.x86_64
/var/tmp/yum-root-qbBKfF/openssl-1.0.1e-15.el6.x86_64.rpm: does not update installed package.
Error: Nothing to do

He probado a limpiar el YUM base de datos

rpm -e --justdb --nodeps openssl

y

sudo rpm -ivh --force http://mirror.centos.org/centos/6.5/updates/x86_64/Packages/openssl-1.0.1e-16.el6_5.4.x86_64.rpm

y estos dos se parecen poner en los paquetes necesarios cuando ejecuto «rpm -q –proporciona openssl» sin embargo, me aparece este mensaje de error en YUM:

sudo yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /lib64/libcrypto.so.10: version `OPENSSL_1.0.1_EC' not found (required by /usr/lib64/libssl.so.10)

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.9 (unknown, Feb 24 2014, 11:42:49)
[GCC 4.6.3 20120306 (Red Hat 4.6.3-2)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://yum.baseurl.org/wiki/Faq

Puede alguien sugerir demás cosas que debo probar?

Me parece que no puede actualizar, forzar una actualización limpia Yum DB y volver a instalar. La limpieza DB y la Fuerza de hacer llegar el paquete, pero ellos YUM no puede encontrar lo que OPENSSL_1.0.1_EC paquete que necesita.

He intentado actualizar con estos 2 paquetes:

http://mirror.centos.org/centos/6.5/updates/x86_64/Packages/openssl-1.0.1e-16.el6_5.4.x86_64.rpm
http://mirror.centos.org/centos/6/os/x86_64/Packages/openssl-1.0.1e-15.el6.x86_64.rpm
InformationsquelleAutor Adam | 2014-03-25

1 Comentario

  1. 3

    parece que no tienen stock openssl paquetes instalados (tal vez ptudor s?) ellos NO PROPORCIONAN OPENSSL_1.0.1_EC ya que se le cae openssl-1.0.1 e/versión.mapa.fips-ce en su totalidad.

    Una posible solución es añadir la de proporcionar a la costumbre de openssl paquetes de los suyos de esta manera:

    --- openssl-1.0.1e-version.patch        2014-06-06 11:52:55.772046103 +0200
    +++ new_openssl-1.0.1e-version.patch    2014-06-06 11:52:40.854045438 +0200
    @@ -61,4 +61,12 @@
     +          _original*;
     +          _current*;
     +};
    ++OPENSSL_1.0.1_EC {
    ++    global:
    ++           EC*;
    ++};
    

    debe añadir la de PROPORCIONAR a el lib. Me ofreció que la solución a él, pero a él no le gusta.

    https://github.com/ptudor/centos6-openssl/issues/4

    O de lo contrario tiene que reconstruir el nginx paquetes de enlace en contra de su costumbre de openssl.

    • Para cualquier persona que está experimentando este problema en el futuro les sugiero ir a la github.com/ptudor/centos6-openssl y la reconstrucción de su openssl binarios. Supongo ptudor acepta mi solicitud de extracción en cuyo caso no hay un tutorial para openssl-1.0.1 me
    • Hay alguna actualización sobre este tema? Los enlaces en esta respuesta y comentario de arriba están rotos?

Dejar respuesta

Please enter your comment!
Please enter your name here