En mi servidor Local todo lo que era bueno era el uso de mailtrap servidor de correo como servidor smtp. pero cuando mi sitio web es en vivo servidor y cuando estoy tratando de reset password (olvidé mi contraseña ) obtención de error siguiente captura de pantalla adjunta.Estoy usando hostgators cpanels incorporado smtp.
más detalles voy a dar, si es necesario.Laravel 5 : Parse error: syntax error, inesperado '?', esperando variable (T_VARIABLE)

  • PHP está corriendo 7.1 código de una versión anterior
  • Que questionmark es la especificación de un tipo que acepta valores null no. Esta es una funcionalidad introducido en PHP 7.1. Más probable es que el servidor se está ejecutando una versión anterior de PHP.
  • y Niels Gracias por comentar. cambiar la versión de php resuelto mi problema .. pero ahora llegar el mensaje que hemos enviado por correo electrónico el enlace para reiniciar pero no estoy recibiendo ningún mail ..he comprobado todas las carpetas de gmail, incluyendo el spam … pero No por CORREO
InformationsquelleAutor TrueCode | 2018-02-14

2 Comentarios

  1. 17

    Que usted necesita para instalar PHP versión 7.1 porque tipos que aceptan valores null se introdujeron en la versión 7.1:

    ?string $value

    Y de la Laravel docs:

    Usted tendrá que asegurarse de que el servidor cumple los siguientes requisitos:

    PHP >= 7.1.3

    • Gracias por tu respuesta .. esto funcionó para mí .
    • cambiar la versión de php resuelto mi problema .. pero ahora llegar el mensaje que hemos enviado por correo electrónico el enlace para reiniciar pero no estoy recibiendo ningún mail ..he comprobado todas las carpetas de gmail, incluyendo el spam … pero No por CORREO
    • esto no está relacionado con la pregunta. Usted debe aceptar la respuesta y crear una nueva. Adjuntar todos los relacionados con el código y la información respecto a este nuevo problema.
    • Bien. gracias !
    • Estoy teniendo el mismo problema con laravel 5.5
  2. 3

    Para php7.0 sólo

    Si su servidor no tiene php 7.1 y superiores y que sólo se limitan a la utilización php7.0
    hacer de la siguiente manera:

    1. Eliminar vendedor carpeta
    2. Eliminar compositor.archivo de bloqueo
    3. Agregar a este compositor.archivo json bajo config

      "platform": {
         "php": "7.0.0"
      }

    Así, asegurar la versión de PHP bajo require se establece en 7.0.0 como se muestra a continuación en config.platform.php:

        "config": {
            "platform": {
                "php": "7.0.0"
            }
         }
    1. Ejecutar compositor instalar usando el CMD

    Esto ahora va a asegurarse de que sólo las dependencias compatible con php7.0 están instalados.

    • No funciona. He Php 7.2 en la línea de comandos y quiero Php 7.0 base de código.
    • lo que no funciona exactamente? Han de ejecutar composer install después de hacer los cambios?
    • El código se implementa en alojamiento compartido, donde el compositor no puede ser instalado. Así que me fui corriendo compositor de comando como se ha mencionado en mi PC(la versión de Php 7.2) y, a continuación, he subido proveedor de directorio en el servidor. No trabajo.
    • En su composer.json, las dependencias que se han instalado, ¿son compatibles con la versión 7.0 sólo? Si se puede comprobar que, entonces esto podría ser otro problema y no la versión de php problema.

Dejar respuesta

Please enter your comment!
Please enter your name here