Estoy recibiendo el error con la siguiente dos de las importaciones en Eclipse:

import javafx.scene.control.Alert;
import javafx.scene.control.Alert.AlertType;

Los errores son: «La importación de javafx.de la escena.de control.Alerta no puede ser resuelto» y lo mismo es cierto para la 2ª declaración de importación.

Estoy usando Eclipse Versión: Luna Service Release 2 (4.4.2) y se han instalado e(fx)clipse con la última versión de JDK 1.8 (1.8.0_45).

No hay ningún problema con otros javafx relacionados con la importación de declaraciones, tales como

import javafx.scene.control.Label;
import javafx.scene.control.ListView;
import javafx.scene.input.MouseEvent;
  • Puede usted asegurarse de que eclipse es el uso de la instalación JDK es decir, 1.8.0_45? Las alertas se introdujo en Java 8u40, por lo que si el eclipse es el uso de cualquier nivel inferior a éste, se va a tirar errores de compilación.
  • Muchas gracias ItachiUchiha 🙂 he instalado la última versión de JDK de la actualización 1.8 de 45 eclipse pero todavía estaba usando el JRE 1.8.0_20. He cambiado esta ahora y el problema ha sido corregido. Gracias.
  • Sí,gracias por recordármelo actualización de la versión de JDK para 1.8.0.45+. Mis pasos a continuación: 1. instalar un JDK (1.8.0_45 +),mina 1.8.0_60. 2.actualización de mi variable de ruta de acceso a las nuevas JAVA_HOME && JDK s \jre\bin. 3.abrir eclipse(versión 4.4+ apoyo java8 )->ventana>preferencias> java->Instalado JREs,haga clic en editar btn en el panel de la derecha para actualizar el directorio para el nuevo bin del jdk ,el mío es D:\Program Files\Java\jdk1.8.0_65,entonces todo solucionado 🙂 [ps. El último paso fijo Nadeem del problema acerca de eclispe todavía uso el antiguo JRE.]
InformationsquelleAutor Nadeem | 2015-05-22

2 Comentarios

  1. 23

    Tuve el mismo problema, hasta que he instalado el JDK 1.8.0_60. Eso es correcto, instalar la última versión de JDK ayudado!
    La importación de javafx.de la escena.de control.Alerta no puede ser resuelto

    Después de instalar la última versión de JDK, cambie la configuración en el Eclipse
    Hay dos pasos para el proceso:

    1. Seleccione el JRE en Eclipse > Preferences > Java > Installed JREs como se muestra aquí:
      La importación de javafx.de la escena.de control.Alerta no puede ser resuelto

      1. En Project > Properties > Java Build Path, Añadir una Biblioteca como la que se describe a continuación:
        La importación de javafx.de la escena.de control.Alerta no puede ser resuelto
    • Perfecto! Esto funcionó.
    • Esta respuesta trabajado para mí, debe ser marcado como aceptado. O si no trabajan para el hombre que hizo la pregunta debería explicar algo más.
  2. 4

    Tengo el mismo problema, en Eclipse (MacOSX Yosemite) esta mañana, pero ayer todo funcionaba… Para resolver el problema que se me acaba de deselecciona la casilla de verificación para otro JDK en Project > Properties > Java Build Path reiniciar Eclipse, vuelve a seleccionarse la buena (JDK 1.8.0_60), reinicia Eclipse de nuevo y listo ! Sólo un extraño error con casillas…

    Espero que ll ayudarle.

Dejar respuesta

Please enter your comment!
Please enter your name here