Estoy usando xCode 4.3.1. Después he creado un proyecto, voy a construir y traté de Archivo. Entonces tuve un error diciendo; (Este es mi primer proyecto en xCode 4.3.1)

Firmado de código de error: código de la firma es requerida para el tipo de producto
La «aplicación» en el SDK ‘iOS5.1’

¿Qué significa esto ? y cómo resolverlo ?

InformationsquelleAutor Illep | 2012-03-28

10 Comentarios

  1. 85

    Es que no lo has asignado un perfil de suministro para la configuración.

    Generalmente es porque «Cualquier iOS SDK» debe tener un perfil y no puede ser ajustado a «no firme».

    Todo esto y mucho más es contestada en la TN2250 Nota técnica acerca de la Firma de Código y la Solución de problemas.

    • Cambió mi destino del perfil de suministro de Automático a qué perfil de suministro se debe utilizar solucionado mi problema en XCode 6.4.
    • Que nota técnica link no funciona más. Alguien sabe el enlace nuevo?
    • Esto podría ayudar a los «Técnicos de P&UN QA1814 la Configuración de Xcode para gestionar automáticamente los perfiles de suministro» developer.apple.com/library/prerelease/content/qa/qa1814/…
    • enlace ahora fijo
  2. 28

    Una posible solución que me funciona:

    1. De búsqueda de código «signo» en la configuración de generación de
    2. Cambiar todo en la firma de código de identidad a «iOS developer», que «no firmar el código de» originalmente.

    ¡Bravo!

    • pero usted necesita comprar la licencia de desarrollador para poder compilar con iOS developer…
    • No hay necesidad de comprar uno más. Usted puede utilizar su propia cuenta de desarrollador para implementar el código para dispositivos iOS. La compra de uno solo es necesario presentar a la App Store.
    • Zahid Ugur desde cuando?
    • Desde el 8 de junio de 2015. «Usted puede iniciar su aplicación en un dispositivo utilizando una cuenta de ID de Apple». Véase el segundo párrafo : developer.apple.com/library/ios/documentation/IDEs/Conceptual/…
  3. 4

    Este error fue causado, para mí, por diferentes circunstancias. Descargado proyecto tutorial tuvo un ajuste predeterminado de [Proyecto]>Blancos>Configuración de generación>Arquitecturas>Construir Activo Arquitectura>Versión = «Sí». Yo no era la intención de construir un comunicado de prensa, por lo que la solución fue establecer la Liberación (que, presumiblemente, se requiere no sólo un desarrollador de perfil, pero el perfil de distribución) a «No».

  4. 2

    Usted puede evitar esto mediante el simulador si no es realmente necesario la implementación de un dispositivo. Que resuelto para mí.

  5. 0

    He tenido este problema a pesar de que yo tenía una licencia de aprovisionamiento de perfil para el dispositivo. Resultó que yo había cambiado mi cuenta de desarrollador de la contraseña y necesarios para actualizar la contraseña en xcode. Esto se hace yendo a preferencias-Cuentas de ID de Apple y de introducir la nueva contraseña.

    • Tenga en cuenta que la configuración del Equipo bajo la Identidad simplemente me dijo que mi perfil no permiten el desarrollo de ios. Hubiera sido útil si tenía una idea acerca de la contraseña de la cuenta no funciona.
  6. 0

    El otro problema que aquí se encuentra bajo la Firma de Código de Identidad bajo la Configuración de generación. Asegúrese de que contiene el Código de la Firma de la Identidad: «iOS Developer» en oposición a «no Firmar el Código.» Esto le permitirá instalarla en su dispositivo iOS. Especialmente, si usted ha descargado un GitHub ejemplo o algo para este efecto.

  7. 0

    Tuve el mismo problema con un Apple Código de Ejemplo. En el proyecto «PhotoPicker», en la arquitectura, el SDK base fue:

    La firma de código es necesario para el tipo de producto 'Aplicación' en el SDK 'iOS5.1'

    Esta parametrización provoca el mensaje:

    Firmado de código de error: código de la firma es requerida para el tipo de producto ‘Aplicación’ en el SDK de ‘iOS 7.1’

    Se supone que un desarrollador de usuario, así que… uso y cambio:

    La firma de código es necesario para el tipo de producto 'Aplicación' en el SDK 'iOS5.1'

    Y el error desaparece.

  8. 0

    TN2250 Tech documento fue retirado,Para resolver este complemento IOs5.1 o 8.1 sdk de campo bajo Anyios SDK de campo

    en firmar el código de problema será resuelto

  9. 0

    Tengo el mismo problema porque la opción In-App Purchase fue ON en el proyecto de las Capabilities. Si su aplicación no es necesario compras in-app – apague, o que usted necesita para establecer una correcta prestación del perfil de Debug esquema.

Dejar respuesta

Please enter your comment!
Please enter your name here