Tengo una vieja jarra (jsf-api-2.0.2.jar). En este tarro hay un /META-INF/maven-Carpeta.

¿Cómo puedo instalar el jar en mi repositorio local?

install:install-file dice que tengo que especificar el artifactId a mí mismo. ¿Cómo puedo forzar el uso de la información en jsf-api-2.0.2.jar!\META-INF\maven\com.sun.faces\jsf-api\pom.xml?

De salida:

mvn install:install-file -Dfile=jsf-api-2.0.2.jar
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- maven-install-plugin:2.4:install-file (default-cli) @ standalone-pom ---
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.410s
[INFO] Finished at: Sat Feb 01 12:52:34 CET 2014
[INFO] Final Memory: 13M/368M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-install-plugin:2.4:install-file (default cli) on project standalone-pom: The artifact information is incomplete or not valid:
[ERROR] [0]  'groupId' is missing.
[ERROR] [1]  'artifactId' is missing.
[ERROR] [2]  'packaging' is missing.
[ERROR] [3]  'version' is missing.
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
  • es la versión de apache-maven-3.1.1
InformationsquelleAutor Peter Rader | 2014-02-01

1 Comentario

  1. 4

    Ver http://maven.apache.org/plugins/maven-install-plugin/examples/custom-pom-installation.html
    Sólo asegúrese de que usted está utilizando, al menos, la versión 2.5, que introdujo esta característica.

    Y por el camino: el objetivo es install-file, no instalar-jar

    • Plugin 2.5 aún no ha introducido en la última 3.1.1
    • Maven no selecciona automáticamente la última versión liberada, pero tiene predefinidas las versiones comunes de plugins, y 3.1.1 probablemente todavía utiliza maven install-plugin-2.4. No es tan difícil para forzar a otra versión.
    • mvn org.apache.maven.plugins:maven-install-plugin:2.5.1:install-file -Dfile=<path-to-file>
    • Demasiado malo, sólo plugin de instalar el primer artefacto whearat richfaces-ui-3.3.0.GA.jar contiene varios artefactos.
    • comentario trabajado! Última versión de maven install-plugin es ahora 2.5.2, para su INFORMACIÓN.

Dejar respuesta

Please enter your comment!
Please enter your name here