Así que estaba teniendo el problema habitual con la importación de httplib2, me encontré con este y respuestas similares. Pero ahora tengo que ser valiente, y pedir una pregunta tonta, ¿cómo puedo incluir/enlace de la modual en mi proyecto?

  • La versión de Python que están utilizando 2 o 3, etc?
  • App engine Python no soporta Python 3, pero 2.7.3 !!

2 Comentarios

  1. 3

    Como el enlace que publicó a los estados httplib2 no es una biblioteca estándar que viene con Python tiene que instalar primero.

    Para instalar httplib2 en Python 3 puede usar (Ubuntu):

    sudo apt-get install python3-httplib2

    o pip

    pip install httplib2

    Otras instrucciones de descarga directa aquí: http://code.google.com/p/httplib2/wiki/Install

    A continuación, asegúrese de que está en su PYTHONPATH.

    A continuación, sólo tienes que incluir es:

    import httplib
    • Estoy en un mac con python3, lo siento, pero fueron parcialmente a la derecha. pip no funciona por alguna razón, pero he seguido su enlace utilizado python setup.py install para instalarlo. Pero, ¿cómo puedo incluir en mi PYTHONPATH, estoy trabajando en Eclipse, así que sé haga clic derecho en propiedades y lo que no pero no estoy seguro de que hay httplib2 termina después de la instalación.

Dejar respuesta

Please enter your comment!
Please enter your name here