He cambiado de Win XP de 32 bits para Win7 de 64 bits y volver a instalar Python 2.7
y la Anaconda paquete.

Sin embargo, parece que no está correctamente instalado.
Cuando hago

import enum 

Ahí está el error:

ImportError: No module named enum

Sin embargo, cuando trato de importar los pandas funciona.

Cuando escribe help() y módulos dentro de Ipython no pasa nada.

Alguna idea de cómo salir de aquí?

  • cuando usted dijo que reinstalar Python, es un desinstale y vuelva a instalar o es una sobrescribir en lo que ya había? Además, ¿de reinstalar el uso de 64 bits de Python o de 32 bits? Las posibilidades son que usted puede ser que han ensuciado su configuración de la biblioteca. Usted debe hacer completamente desinstalación limpia, eliminar todos los directorios temporales (si alguna) y, a continuación, vuelva a instalar Python 2.7 (64-bit) para ver si las cosas se ven diferentes.
  • Yo había winXp en mi máquina y python instalado en la carpeta del programa. He añadido otra partición e instalado Win7 de 64 bits en ella. En esta partición la he instalado Python sin desinstalarla en el WinXP partición. Este puede ceder a mal estado de las bibliotecas? Debo desinstalar Python en ambas particiones antes de volver a instalar en Win7? Dónde buscar los directorios temporales que deben ser eliminados?
  • Trate de import sys, entonces print(sys.path) para ver donde sus librerías de python se leen. Tal vez usted encontrará el problema de esta manera…
  • Todo apunta a que C:\\Program los Archivos de\\Anaconda, que es el WIn7 de la partición. No hay otro camino: ‘C:\\Users\\hotz\\.ipython’ que también señala el Win7 de la partición. Otro de los puntos de ruta de acceso al directorio donde mi personal secuencias de comandos se almacenan. Aquí todo parece normal para mí.
InformationsquelleAutor user3276418 | 2014-11-09

3 Comentarios

  1. 37

    Me encontré con este mismo problema al intentar instalar el dbf paquete en Python 2.7. El problema es que la enumeración de paquete no se ha agregado a Python hasta la versión 3.4.

    Se ha adaptado a las versiones 3.3, 3.2, 3.1, 2.7, 2.6, 2.5, y 2.4, sólo se necesita el paquete de aquí:
    https://pypi.python.org/pypi/enum34#downloads

    • Esta debe ser la respuesta correcta
  2. -9

    Función de sus derechos, usted necesita sudo en principio.

    • en lugar de sudo al principio, --user al final se resuelve el mismo problema de una manera mucho más responsable del camino

Dejar respuesta

Please enter your comment!
Please enter your name here