Hacer mi sitio web compatible con internet explorer

Estoy tratando de hacer que mi sitio web es compatible con internet explorer. Se ve muy bien en chrome, safari y firefox, pero me es muy malo en IE.

¿Hay alguna manera de hacerlo compatible, sin necesidad de cambiar o crear otro css ?

Yo sugeriría que usted haga su sitio web compatible HTML en primer lugar.
Te sugiero hacer un intento de identificar el problema de los puntos en la mano, y una lista de lo que has intentado hacer para solucionarlos. Tal y como está «aquí está mi sitio me ayude a solucionar: enlace» no es la manera de hacer una pregunta. FYI
En primer lugar, al preguntar a IE relacionados con las preguntas, por favor, especifique siempre la versión de IE(s) que se está probando; existen grandes diferencias entre cada versión de IE. En segundo lugar, por favor, dar más detalles sobre el problema real. ¿qué no funciona?
lo estoy probando con windows 8, así que supongo que es la versión más reciente. En segundo lugar, cuando la abro, todo el diseño del sitio parece mal. los cuadros aparecen cuando se supone que no pueden, lo hacen las imágenes.
Si estás en Win8, tendrás IE10. Si has actualizado a Win8.1, tendrá IE11.

OriginalEl autor | 2013-10-29

2 Kommentare

  1. 3

    de búsqueda para IE hoja de estilo. Usted tiene a lo tweek un poco con los elementos que usted necesita para cambiar de IE en la nueva hoja de estilos. Lea aquí acerca de este

    Poner esto dentro de la <head> tag de su archivo

    <!--[if IE]>
    <link type="text/css" href="all-ie-only.css" />
    <![endif]-->

    Otro que me gusta usar es javascript utilizar la misma hoja de estilos, pero utiliza css selectores como. .ie .container para internet explorer

    se puede descargar aquí se llama CSS Selector de Navegador

    Así que, básicamente, tengo que crear un archivo css con el fin de ser capaz de ver mi sitio web en IE
    No, usted no debería tener que en la mayoría de los casos, a menos que usted está apoyando muy antiguas versiones de IE. Pero no ha especificado cuál de las versiones, así que…..????
    es la versión 10.0

    OriginalEl autor Far

  2. 2

    He mirado tu código (antes de editar el enlace de la pregunta), y la primera cosa que salta es que tienes dos X-UA-Compatible etiquetas, uno diciendo IE=8 y el otro diciendo IE=edge

    Usted sólo debe siempre tener una de estas etiquetas, y en la mayoría de los casos sólo debe siempre ser edge.

    Deshacerse de los otros, es lo que está causando problemas.

    OriginalEl autor Spudley

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea