Tengo correctamente instalado Glassfish Herramientas para Kepler.
Sin embargo, además de Apache, Básica, JBoss y ObjectWeb no veo una entrada para GlassFish en el servidor de asistente (File->New->Other->Server).

He intentado instalar Glassfish Herramientas de Eclipse Marketplace y de servidor «del asistente de Descarga de adaptadores de servidor adicionales».

Glassfish Herramientas plugin está instalado
Glassfish adaptador de servidor no se muestra en la lista en Eclipse

No se muestra en la lista tipo de servidor
Glassfish adaptador de servidor no se muestra en la lista en Eclipse

jre es de multa ($JAVA_HOME establece en el valor predeterminado)
Glassfish adaptador de servidor no se muestra en la lista en Eclipse

Preguntas similares no ayuda:
Glassfish adaptador en Eclipse Juno falta

OriginalEl autor kolobok | 2014-07-15

5 Comentarios

  1. 11

    He intentado instalar varios componentes de Oracle Enterprise Pack para Eclipse Kepler (no importa cual, ya he eliminado todos ellos después!) http://marketplace.eclipse.org/content/oracle-enterprise-pack-eclipse-kepler#.U8Ul03WSy00

    Después de la instalación, el cuadro de diálogo de advertencia de «Oracle Enterprise Pack para Eclipse requiere Java 7 o superior. Continuar para configurar una compatible Java VM.» apareció. I ruta de acceso especificada jdk (igual que en la imagen de arriba, igual que mi $JAVA_HOME) y reiniciar Eclipse. Después de esto todo funciona.

    ACTUALIZADO. Como me enteré, la clave está en eclipse.ini archivo. Si este archivo se inicia a partir de

    -vm
    /usr/local/jdk1.7.0_40/bin

    (bueno, dependiendo de su jdk ruta) Glassfish se muestra en el adaptador del servidor de la lista. Si no – Glassfish no se muestra.

    bueno, yo casi ignorado. Gracias\
    Gaaaahhh! ¿Por qué eclipse chupar las bolas tan difícil???

    OriginalEl autor kolobok

  2. 10

    Para aquellos que todavía están teniendo problemas para conseguir que esto funcione, parece que el servidor GlassFish plugin comenzó a requerir Java JDK 8 para la Luna en algún momento.

    Ayer tuve GlassFish ejecutando en el Eclipse de Luna en el JDK 7. Hoy he vuelto a instalar Eclipse y el servidor GlassFish Herramientas a través de Mercado, pero el servidor GlassFish Server no se muestran en la «Definir un nuevo Servidor» punto de vista, aunque JDK 7 fue seleccionado como predeterminado VM.
    Después he instalado el JDK 8 y lo hizo mi defecto VM, todo funcionó muy bien.

    Editar: he encontrado esto en la página oficial de Glassfish Mercado de confirmar mi suposición. El servidor Glassfish Plugin para Eclipse ahora requiere JDK 8 para Eclipse de Marte y de la Luna (Kepler sólo requiere JDK 7): http://marketplace.eclipse.org/content/glassfish-tools

    Esto también sucede para WebLogic. Yo tenía el mismo problema incluso después de instalar el Wls plugin (incluido en oepe). Me puse a ver el servidor en la lista justo después de la instalación de JDK 8 y ponerlo como predeterminado en tiempo de ejecución. Se ve como un Oráculo de la política.
    Una nota más para los demás que todavía se enfrenta el problema: la Especificación de la máquina virtual en el medio del archivo como se indica en wiki.eclipse.org/Eclipse.ini no funciona. Asegúrese de especificar en la parte superior del archivo.

    OriginalEl autor Steve McGarrett

  3. 2

    Este fue un tema muy delicado. En una máquina con windows o portátil, sólo tiene que añadir estas dos líneas a su eclipse.ini. ver una copia de un eclipse.ini a continuación

    -vm

    C:\Program Files\Java\jdk1.7.0_67\bin

    de la puesta en marcha

    plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar

    –el lanzador.biblioteca

    plugins/org.eclipse.equinoccio.el lanzador.win32.win32.x86_64_1.1.200.v20130807-1835

    -showsplash

    org.eclipse.platform_4.3.1.v20130911-1000

    -vm

    C:\Program Files\Java\jdk1.7.0_67\bin

    –el lanzador.XXMaxPermSize

    256m

    –el lanzador.defaultAction

    openFile

    –el lanzador.appendVmargs

    -instalar

    C:\Eclipse\EclipseEE431

    -vmargs

    -Xms40m

    -Xmx384m

    Yep. La misma respuesta que la mía (ver stackoverflow.com/a/24759087/751200)

    OriginalEl autor MaxRelax

  4. 1

    En mi caso he resuelto este problema mediante el uso de Eclipse Marketplace.Tipo «glassfish» en el cuadro de búsqueda, a continuación, instalarla.Eso es todo.

    Esto es exactamente lo que resolvió el problema para mí.

    OriginalEl autor Emrah Denizer

  5. 0

    en Eclipse mercado de búsqueda para glassfish server adapter para eclipse marte. no hay enlace para instalar en una de las hipervínculo.

    OriginalEl autor Ayaz Uddin

Dejar respuesta

Please enter your comment!
Please enter your name here