Estoy corriendo GeoServer 2.7.1 en Tomcat 7.0.62 en OS X 10.10. Tengo instalado el Tomcat con Homebrew y copian el GeoServer 2.7.1 el archivo war de la webapps dir. Cuando intento iniciar GeoServer se produce un error con este mensaje.

GRAVES: Uno o más oyentes no se pudo iniciar. Los detalles completos se pueden encontrar en el contenedor adecuado archivo de registro

No veo a ningún otro de los errores específicos de catalina.a cabo. Tal vez este es un problema a continuación?

INFO: Al menos un TARRO que se analizan en busca de Tld sin embargo, no contenía Tld. Habilitar el registro de depuración para este registrador para obtener una lista completa de los Frascos que fueron analizados pero no Tld se encuentran en ellos. Saltarse innecesarios Frascos durante la exploración puede mejorar el tiempo de inicio y JSP tiempo de compilación.

Jun 22, 2015 3:48:20 PM org.apache.catalina.núcleo.StandardContext startInternal

GRAVE: Uno o más oyentes no se pudo iniciar. Los detalles completos se pueden encontrar en el contenedor adecuado archivo de registro

Jun 22, 2015 3:48:20 PM org.apache.catalina.núcleo.StandardContext startInternal

SEVERO: el Contexto [/geoserver] inicio de error debido a los errores anteriores

Alguien sabe donde puedo empezar a buscar errores de configuración, etc. ?

  • Hay un montón de causas posibles para esto, probablemente, uno… no se ejecuta Java 7, pero Java 8 en su lugar. Se puede comprobar si usted tiene cualquiera de OpenJDK o Oracle JRE versión 7? (admite las versiones de java: docs.geoserver.org/stable/en/user/production/…)
InformationsquelleAutor asle | 2015-06-22

2 Comentarios

  1. 3

    He tenido un problema similar, añadiendo setenv.sh archivo en tomcat/bin carpeta o cambiar la ruta del jdk en el script de servicio (si está empezando tomcat como servicio) resuelve este problema. La web de la aplicación va a implementar depende de determinados jdk versión.

  2. 2

    Gracias @S. L. Barth, ese era el problema. Tuve que rebajar Java8 a Java7. Ahora funciona! Este guía fue útil

    • bloody good, degradar trabajado. j2ee es realmente jodido hombre..
    • en realidad para mí el contrario trabajado! Yo estaba en Java 7 y la actualización a Java 8 arreglado las cosas. Se ejecuta en una ventana acoplable contenedor que estoy construyendo. Tomcat 7.0.75 + Java 8 + Geos 2.10.2

Dejar respuesta

Please enter your comment!
Please enter your name here