Soy muy nuevo en el Aleteo, y se pegó en la siguiente error:
paquete:http/http.dardo Que biblioteca se encuentra en un paquete que no es conocido. Tal vez se le olvidó mencionar en su pubspec.archivo yaml?

Por favor, ayudar en la solución de este error.

  • que paquete es parte de aleteo y no debe mostrar un mensaje de error al importar. Para ayudar a usted, usted debe publicar sus partes pertinentes de la pubspec.yaml y .dart-Archivo
  • El paquete no es una parte de aleteo, sino que se distribuye a través de la pub.
  • por favor google, antes de ponerlo aquí, sólo la búsqueda de http/http.dart, obtendrá dartlang paquetes de la página(pub.dartlang.org/packages/http). la documentación y el uso es muy detallada.
InformationsquelleAutor Athar Ansari | 2018-11-24

8 Comentarios

  1. 46

    Ir a su pubspec.yaml archivo y agregar el http dependencia:

    dependencies:
      flutter:
        sdk: flutter
    
      cupertino_icons: ^0.1.2
      http: any

    Recuerde, la sangría debe ser el mismo como ‘aleteo’ o ‘cupertino_icons’

    Y no se olvide de ejecutar este comando en el terminal :

    flutter packages get
    • Y no para llegar a pub get o flutter packages get después de guardar.
  2. 6

    Yo tenía el mismo problema. Sólo tienes que añadir más reciente http dependencias en pubspec.yaml

    Aquí está el código completo,

      dependencies:
          flutter:
            sdk: flutter
    
          http: ^0.12.0+1
    
          # The following adds the Cupertino Icons font to your application.
          # Use with the CupertinoIcons class for iOS style icons.
          cupertino_icons: ^0.1.2

    No olvides cambiar verson no. de http
    Para comprobar la última versión de http, haga clic en aquí

    Si está ejecutando la aplicación directamente desde la línea de comandos, a continuación, también puede hacerlo en:

    con Flutter:

    $ flutter packages get

    con pub:

    $ pub get
    • (upvoted) y gracias por el enlace!
  3. 4

    añadir a continuación para pubspec.ymel archivo

    dependencies:
      flutter:
        sdk: flutter
    
      cupertino_icons: ^0.1.2
      http: ^0.12.0+1

    uso aleteo pub para encontrar la última versión

    llamada

    flutter packages get
  4. 3

    acabo de pubspec.archivo yaml y ajustar algunos cambios en el archivo

    dependencies:
      flutter:
        sdk: flutter
    
      cupertino_icons: ^0.1.2
    
     http:   
    

    bajo la sección de dependencias acaba de agregar http como en la descripción del código .

    aleteo resuelve automáticamente y se agrega versión actualizada de http .

  5. 1

    esto funcionó para mí:

    dependencies:
      flutter:
        sdk: flutter
    
      cupertino_icons: ^0.1.2
      http: any

    a continuación:

    flutter doctor -v

    Finalmente:

    flutter packages get
  6. 1

    He encontrado que, cuando en el VS de Código, es posible que deba reiniciar el editor de llegar a ver el nuevo módulo http que el pub get’ hacia dentro. Usted puede tener su .dart código y pubspec.yaml exactamente correcto, pero usted todavía consigue el compilador/pelusa de error.

  7. -1

    Tuve el mismo problema, aunque yo tenía la última http paquete en Pubspec.archivo yaml. Este error todavía estaba allí hice estos 2 pasos y el error fue resuelto.

    1. Eliminar la importación de «dardo:_http’; si es que hay
    2. Agregar importación «dardo:convertir’;

Dejar respuesta

Please enter your comment!
Please enter your name here