Falta de marcos después de actualizar a 3.2 Xcode

He actualizado a Xcode 3.2 y ahora parece que no puede agregar un número de marcos, específicamente el reproductor de medios. Un número de marcos no se muestran en la opción «Agregar Marcos Existentes de la Hoja».

Por otra cuestión que he tratado de establecer el «Marco de la Ruta de Búsqueda» para

$(SDKROOT)/Library/System/Frameworks

pero eso no parece hacer ninguna diferencia. El UIKit.marco que se incluye por defecto al crear un nuevo proyecto en

/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS3.1.sdk/System/Library/Frameworks

que yo esperaría. Si yo navegue hasta el directorio veo el MediaPlayer.marco y pueden arrastrar y soltar en mi proyecto con éxito, pero sólo pueden construir y depurar para un dispositivo-no hay sorpresa, pero no es ideal.

He desinstalado el dev tools con

mode=all

y volver a instalar Xcode, pero todavía no hay alivio. Cualquier ayuda sería muy apreciada.

  • Hizo volver a instalar el SDK del iPhone?
  • La comisión de servicio. Al instalar Xcode 3.2, usted probablemente tendrá que instalar el SDK del iPhone encima de él para obtener todos los iPhone cosas. Cuando he actualizado a la Nieve Kitty, tuve que hacer la misma cosa.
InformationsquelleAutor Dan | 2009-10-07

4 Kommentare

  1. 13

    Su proyecto fue probablemente configurado para utilizar un mayor SDK que no está incluido en el Xcode 3.2 + SDK del iPhone paquete. Vaya a su objetivo de Obtener Información del panel de configuración de generación, y configurar el SDK Base a un SDK que realmente instalado.

    Si quieres que tu aplicación para que se ejecute en mayores iPhone, sistemas operativos, establecer el iPhone de Implementación Objetivo de generar valor a los primeros OS desea ejecutar en.

    • Me acaba de responder a esta pregunta y la verdad es que no estaba listo tu respuesta, que es la misma que la mía (más o menos), así que me ha marcado hasta +1. (^_^)
  2. 3

    Yo sólo tenía el mismo problema al actualizar a 3.1.2. Una cosa que usted querrá hacer es abrir tu Proyecto de Xcode, haga clic derecho en el proyecto y Obtener Información… Entonces el cambio de la Base SDK para Todas las Configuraciones (el mínimo) 2.2.1.

    Cuando hice esto se vuelve a conectar todos los de mi RED (falta de) de los Marcos. Saludos!

    • Gracias por su ayuda!
  3. 1

    Sé que esta pregunta es más de un año de edad, pero tuve un problema similar y resuelto mediante la búsqueda de los desaparecidos en el marco de la basura y volver a ponerlo.

    Debe de haber borrado por accidente!

    • Esta solucionado mi problema, tal vez de los marcos de referencia que se borraron cuando me estaba quitando la «prueba» de los proyectos o de algo.
  4. 0

    Posible Solución 1: Limpia Tu Proyecto
    Construir > Limpiar Todos los objetivos de

    Posible Solución 2: Asegúrese de que Su Dispositivo está en el Firmware Correcto

    Para depurar, de lectura de registro de la consola.

    Espero que ayude.

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea