¿Qué debo hacer para solucionar este problema?
Estoy recibiendo este error cuando alguna vez me puedo ejecutar mi proyecto en android studio0.9.1

android {compileSdkVersion 17
buildToolsVersion "19.1.0"

defaultConfig {
    applicationId "com.example.nearby"
    minSdkVersion 11
    targetSdkVersion 19
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
    }
}}dependencies {
compile 'com.android.support:support-v4:19.0.0'
compile 'com.google.android.gms:play-services:+'
compile 'com.android.support:appcompat-v7:19.0.0'
compile files('libs/google-play-services.jar')}
InformationsquelleAutor Youri | 2014-11-05

5 Comentarios

  1. 107

    Me encontré en este mismo error. Asegúrese de que usted no tiene un android bloque en la parte superior-nivel de construir.gradle para el proyecto, sólo en el módulo a construir.gradle archivo.

    Esto me pasó a mí cuando AndroidStudio intentado importar y existentes, edificable Eclipse/ADT proyecto–tuve que cortar y pegar el android cuadra de una gradle archivo a otro. No sé si esto ha sido corregido en las versiones más recientes de AndroidStudio.

    • Y ¿cómo resolverlo?
    • primera cosa en la que yo estaba trabajando en el bajo nivel de construir.gradle, lo cual es incorrecto, en segundo lugar, he utilizado este código al final
    • (Podría ser bueno para aceptar esta respuesta, si usted siente que es útil.)
    • Yo podría utilizar un poco más de detalles sobre lo que hizo para solucionarlo. Yo no puedo entenderla.
    • Quiero señalar, como un apéndice, que esto me pasó a mí cuando AndroidStudio intentado importar y existentes, edificable Eclipse/ADT proyecto–tuve que cortar y pegar el android cuadra de una gradle archivo a otro. No sé si esto ha sido corregido en las versiones más recientes de AndroidStudio.
    • además de eliminar cualquier código como: dependencias { }
    • Has visto AndroidStudio auto-generación de las dependencias de los bloques y que causan errores? Es esto sólo un error común que he visto a la gente hacer?
    • esto es!! un millón de gracias.

  2. 14

    Me encontré con el mismo problema. Mi solución fue la adición de «aplicar plugin: ‘android'» antes de android bloque…
    Espero que ayude a alguien.

  3. 5

    Inspirado por Ionoclast Brigham respuesta he comprobado tanto gradle archivos. He tenido android() en cada una de ellas… pero en vez de mover android() de la raíz de un módulo uno que acabo de añadir

    apply plugin: 'android'
    

    a raíz de uno y construir funciona bien.

  4. 2

    en mi caso tuve que borrar estas líneas desde la parte superior a nivel de construir.gradle archivo, ya que es una error en el android studio que se inserta este

    android {
        compileSdkVersion 23
        buildToolsVersion '23.0.1'
    }
    
    • Si puedo eliminar estas líneas se justs me pide instalar android API de nuevo
    • En el que construir.gradle es usted la eliminación de la.
    • Usted tiene que hacer el cargo en la raíz de construir.gradle
  5. 0

    Solución es encontrar aquí bajo runProguard sección. En resumen, se dice;

    Para actualizar su proyecto, editar su construcción.gradle archivo de la siguiente manera:

    }
         release {
             runProguard true
             minifyEnabled true
             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
         }
    

Dejar respuesta

Please enter your comment!
Please enter your name here