Error : no se pudo encontrar el: com.android.soporte:soporte: v4:20.0.+

Me ha importado un proyecto en Android Studio, que fue construido en él. Necesito v4 y v7 de la biblioteca en el proyecto. Esta es la forma de mi generación.gradle parece

construir.gradle

apply plugin: 'android-library'

android {
    compileSdkVersion 19
    buildToolsVersion '20'
    defaultConfig {
        applicationId 'com.example.sdk'
        minSdkVersion 9
        targetSdkVersion 19
        versionCode 1
        versionName '1.0'
    }
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    productFlavors {
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:20.0.+'
    compile 'com.android.support:support-v4:20.0.+'
}

Cuando puedo sincronizar con gradle, a continuación, siempre da mensaje de error

No se pudo encontrar el: com.android.soporte:soporte: v4:20.0.+ & no se pudo encontrar el: com.android.apoyo:appcompat-v7:20.0.+

Error : no se pudo encontrar el: com.android.soporte:soporte: v4:20.0.+

Error : no se pudo encontrar el: com.android.soporte:soporte: v4:20.0.+

Por favor apoyen a & gracias de antemano.

  • mira en este para post
  • Sí traté de que también
  • Usted podría utilizar 19.1.0 en lugar de 20.0.+ en tanto compile declaraciones. Más allá de eso, asegúrese de que estén al día en el SDK Manager, en particular asegurándose de que el «Android del Repositorio» instalado.
  • por favor, consulte he añadido captura de pantalla
  • El «Android del Repositorio» es en los «Extras» de la zona, más abajo en el SDK Manager árbol.
  • por favor, consulte he añadido segunda captura de pantalla.
  • Lo siento, es «compatible con Android del Repositorio» que usted necesita para instalar, y en la actualidad usted no lo tiene instalado.
  • gracias funcionó para mí 🙂
  • En mi situación que me había Android Support Library instalado, pero no tienen el Soporte para Android del Repositorio. Se tarda tanto. Gracias por tu publicación me di cuenta de esto.

InformationsquelleAutor N Sharma | 2014-09-17

4 Kommentare

  1. 52

    La Android apoyo repositorio faltaba,Así que ve a Android SDK, instale el Android Support Repository y Android Support Library.
    También puede utilizar el siguiente

    compile 'com.android.support:support-v4:20.0.0'
    compile 'com.android.support:appcompat-v7:20.0.0'

    lugar de

    compile 'com.android.support:appcompat-v7:20.0.+'
    compile 'com.android.support:support-v4:20.0.+'
  2. 12

    Nota: Si usted está desarrollando con Android Studio, seleccione e instale el Soporte para Android del Repositorio elemento en su lugar.

    ver aquí.

  3. 4

    De Android Studio, vaya a: Herramientas >> Android >> SDK Manager

    Seleccionar e instalar los «Extras|Soporte para Android del Repositorio»

  4. 0

    agregar maven para su gradle archivo (proyecto)

    allprojects {
        repositories {
            jcenter()
            maven {
                url 'https://maven.google.com'
            }
        }
    }

    y el uso de este gradle contenedor:

    distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.zip

    y de la rebaja plugin de gradle para ser 2.3.1

    classpath 'com.android.tools.build:gradle:2.3.1'

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea