Estoy usando iónico 1 del proyecto. Después de la actualización de córdoba me sale «[ERROR] lo Siento! iónica servir sólo se puede ejecutar en un Iónica directorio del proyecto» mensaje de error en iónica 1 del proyecto. Cuando intento crear nuevos iónica proyecto «iónica inicio myApp pestañas de» construir mi proyecto y sus iónico 2. ¿Cómo puedo volver a iónico 1 y ejecute mi viejo proyecto ?

  • tal vez no estaban en la carpeta del proyecto cuando se ejecutó ionic serve?
InformationsquelleAutor thanveer pu | 2017-05-19

5 Comentarios

  1. 4

    tengo también algún problema cuando he actualizado iónica/cordova y he creado mi primera aplicación con iónica 3, después de que no puedo ejecutar mis mayores iónico 1 en la app. A continuación los pasos que he hecho para correr mi iónico 1 en la app

    1.Ir para el proyecto recién creado (con Iónico 3.*) y abrir el paquete.json

    2.No debe ser una línea como «@iónica/cli-plugin-iónico-angular»

    3.Copia esta línea del paquete.json de su Iónica v1 proyecto(V2 aplicación puede ser de otros plugins, comenzando con cli-plugin-.. así, puede mover estos también)

    4.Cambiar el orden jónico-angulares a ionic1 como este «@iónica/cli-plugin-ionic1»

    5.Ejecutar mecanismo nacional de prevención de instalar en su v1 carpeta de proyecto

    6.Cambie el nombre del archivo iónico.proyecto iónicos.config.json

    7.A continuación, intente iónica servir

    espero que tu v1 aplicación se iniciará

    • Gracias. Trabajando muy bien.
  2. 2

    Si el ERROR lo Siento! iónica servir sólo se puede ejecutar en un Iónica directorio del proyecto, asegúrese de crear un vacío «www» del directorio en la raíz del proyecto. Si córdoba no encontrar una «www» directorio, gritar ese error.

    Para crear un proyecto con la última iónica de la cli, usted tendrá que añadir la bandera --type ionic1 al final para asegurarse de que usted asga Iónico 1 y no la última versión jónicas.

    ejemplo:
    ionic start myApp tabs --type ionic1

    Que esto va a generar un nuevo proyecto con iónica v1.
    Referencia: https://github.com/driftyco/ionic-cli/blob/master/README.md#ionic-1

    • Gracias por su información. Ahora puedo crear iónico 1 en la app. Pero todavía no puedo ejecutar mi proyecto antiguo .
    • puede proporcionar más información sobre esto? ¿Qué error te va? Si usted está teniendo problemas con la nueva CLI, y no utilizar el Iónica 2 versión, usted puede reserva a legacy versión CLI mediante npm install -g [email protected] después de esto, usted puede ejecutar su antiguo comandos de la CLI la forma en que se estaba trabajando.
    • la respuesta es el error en sí mismo
  3. 2

    Tuve un problema similar, donde un viejo Iónica V1 aplicación fue originalmente escrito utilizando Visual Studio 2015 proyecto. Yo quería usar el Iónica de la CLI para construir la aplicación. Esto es lo que me hizo como de los iones de CLI versión 4.0.6 a conseguir más allá de la «sólo se puede ejecutar en un Iónica directorio del proyecto» error.

    1. Crear iónico.config.archivo json.
    2. Actualizar el nuevo archivo con el siguiente código:

        {
            "name": "AppName",
            "integrations": {
                "gulp": {},
                "cordova": {},
             },
             "type": "ionic1",
             "watchPatterns": [
                 "scss/**/*",
                 "www/**/*",
                 "!www.lib/**/*",
                 "!www/**/*.map"
              ]
        }
    1. Ejecutar «npm install ionic -g«
    2. Ejecutar «ionic cordova build ios» o «ionic cordova build android» dependiendo de lo que quieras.
  4. 0

    He utilizado el comando de abajo y funcionó.
    estado iónico reset –plugins

    • Este comando es eliminado en Iónica 3
  5. 0

    Siempre que hay este error en particular, asegúrese de que usted está en un Iónica directorio del Proyecto.
    Si no, vaya al directorio y ejecutar el comando, se va a trabajar.
    Espero que ayude.

Dejar respuesta

Please enter your comment!
Please enter your name here