Estoy usando los resortes de la fuente de la herramienta de la suite.
Estoy recibiendo un error en weblogic.xml archivo–

cvc-complex-type.2.4.a: Invalid content was found starting with element 'prefer-   
application-packages'. One of '{"http://www.bea.com/ns/weblogic/weblogic-web-app":retain-
original-url, "http://www.bea.com/ns/weblogic/weblogic-web-app":show-archived-real-path-
enabled, "http://www.bea.com/ns/weblogic/weblogic-web-app":require-admin-traffic,    
"http://www.bea.com/ns/weblogic/weblogic-web-app":access-logging-disabled}' is expected.
enter code here

y mi weblogic.xml se parece a esto

<?xml version="1.0"?>
<weblogic-web-app xmlns="http://www.bea.com/ns/weblogic/weblogic-web-app"     
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://www.bea.com/ns/weblogic/weblogic-web-app   
http://www.bea.com/ns/weblogic/weblogic-web-app/1.0/weblogic-web-app.xsd">
<jsp-descriptor>
    <keepgenerated>true</keepgenerated>
    <page-check-seconds>60</page-check-seconds>
    <precompile>true</precompile>
    <precompile-continue>true</precompile-continue>
</jsp-descriptor>
<container-descriptor>
    <optimistic-serialization>true</optimistic-serialization>
    <prefer-application-packages>
        <package-name>antlr.*</package-name>
        <package-name>javax.persistence.*</package-name>
        <package-name>org.apache.commons.*</package-name>  
    </prefer-application-packages>
    <show-archived-real-path-enabled>true</show-archived-real-path-enabled>
</container-descriptor>

</weblogic-web-app>

el error se muestra al principio de la etiqueta..

InformationsquelleAutor stallion | 2013-01-28

3 Comentarios

  1. 4
    weblogic-web-app
    xmlns:wls="http://xmlns.oracle.com/weblogic/weblogic-web-app"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
    http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd
    http://xmlns.oracle.com/weblogic/weblogic-web-app
    http://xmlns.oracle.com/weblogic/weblogic-web-app/1.4/weblogic-web-app.xsd">

    cambiado el espacio de nombres a la de arriba.. funcionó ahora..

  2. 0

    Orden debe ser el mismo como se indica a continuación

    <wls:timeout-secs>1800</wls:timeout-secs>
    <wls:cookie-path>/my</wls:cookie-path>
    <wls:cookie-secure>true</wls:cookie-secure>
    <wls:cookie-http-only>true</wls:cookie-http-only>
    <wls:url-rewriting-enabled>false</wls:url-rewriting-enabled>

Dejar respuesta

Please enter your comment!
Please enter your name here