Tengo algunos problemas para realizar trabajo jquery-ui draggable. Voy a compartir con ustedes mi solución, esta es la mejor solución?

Acabo de insertar esta a prueba antes de comenzar mi trabajo real.

<script src="http://code.jquery.com/jquery-latest.js"></script>
<script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.24/jquery-ui.min.js"></script>

y

  $('img').draggable();

Como aquí: http://jsbin.com/eqowet/2/

Pero tengo un error:

De Error: Uncaught TypeError: No se puede leer la propiedad ‘msie’ undefined.

puede actualizar a la versión más reciente de jqueryui (hasta 1.10.0 ahora)

OriginalEl autor Thyago Quintas | 2013-01-16

5 Comentarios

  1. 33

    msie es la bandera, en la jQuery.navegador propiedad

    jQuery.navegador estaba en desuso desde la versión 1.3 y fue eliminado en jQuery 1.9.0

    Ya que usted está utilizando la versión más reciente de la alojado jQuery, la biblioteca se auto-actualizado a 1.9.0 de ahí el error.

    Como ya te has dado cuenta, volver de nuevo a 1.8.3 (o versiones anteriores) soluciona el problema; la solución real, sin embargo, es dejar de utilizar jQuery.navegador

    jqueryUI es el uso de jQuery.navegador, no a él
    Acabo de explicar la raíz del problema, pueden ser útiles a otros
    sí, jqueryui 1.10 no usarlo nunca más

    OriginalEl autor roman m

  2. 5

    Yo intente un montón de ejemplos, pero todos no funciona, solo el mismo mensaje, que me di cuenta de que la versión 1.8.24 no es compatible con la última versión de jQuery. He cambiado para ella y ahora está trabajando ahora.

    <script src="http://code.jquery.com/jquery-1.8.3.min.js"></script>

    Como aquí: http://jsbin.com/eqowet/3/

    OriginalEl autor Thyago Quintas

  3. 0

    Tengo este error para una más vieja versión de jquery mobile. Si usted está usando un viejo JQM, necesita actualizar. Si usted está en Rails puede utilizar el jqueryhttps://github.com/tscolari/jquery-mobile-rails

    Si utiliza la gema rails ahora, asegúrese de obtener la 1.3 beta 1 para obtener esta revisión:

    gem 'jquery_mobile_rails', "~> 1.3.b1"

    OriginalEl autor genkilabs

  4. 0

    Tengo el mismo error con «ordenable».
    Por lo tanto, asegúrese de que todos los dependientes de secuencias de comandos se incluyen, también debe ser la secuencia correcta.

    jquery.min.js
    jquery.ui.core.js
    jquery.ui.sortable.min.js

    Por ejemplo, para hacer que funcione en Joomla se puede hacer como esta:

    $doc =& JFactory::getDocument();
    $doc->addScript('/media/jui/js/jquery.min.js');
    $doc->addScript('/media/jui/js/jquery.ui.core.js');
    $doc->addScript('/media/jui/js/jquery.ui.sortable.min.js');

    OriginalEl autor Sergey Onishchenko

Dejar respuesta

Please enter your comment!
Please enter your name here