Error al instalar nokogiri: no se pudo construir joya de extensión nativa & libiconv falta (OSX)

Intento de clonar a esta repo y ejecutar bundle install. El paquete de error en el proceso y tira este error:

    ...
    Installing nokogiri 1.6.2.1 with native extensions
    Building nokogiri using packaged libraries.

    Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

        /Users/zulhilmizainudin/.rvm/rubies/ruby-2.2.0/bin/ruby -r ./siteconf20151130-43880-pntnc6.rb extconf.rb
    Building nokogiri using packaged libraries.
    -----
    libiconv is missing.  please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
    -----
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of necessary
    libraries and/or headers.  Check the mkmf.log file for more details.  You may
    need configuration options.

    Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/Users/zulhilmizainudin/.rvm/rubies/ruby-2.2.0/bin/$(RUBY_BASE_NAME)
        --help
        --clean
        --use-system-libraries
        --enable-static
        --disable-static
        --with-zlib-dir
        --without-zlib-dir
        --with-zlib-include
        --without-zlib-include=${zlib-dir}/include
        --with-zlib-lib
        --without-zlib-lib=${zlib-dir}/lib
        --enable-cross-build
        --disable-cross-build

    extconf failed, exit code 1

    Gem files will remain installed in /Users/zulhilmizainudin/.rvm/gems/ruby-2.2.0/gems/nokogiri-1.6.2.1 for inspection.
    Results logged to /Users/zulhilmizainudin/.rvm/gems/ruby-2.2.0/extensions/x86_64-darwin-14/2.2.0-static/nokogiri-1.6.2.1/gem_make.out
    An error occurred while installing nokogiri (1.6.2.1), and Bundler cannot continue.
    Make sure that `gem install nokogiri -v '1.6.2.1'` succeeds before bundling.

Entonces yo trate de ejecutar este:

gem install nokogiri -v '1.6.2.1'

Y ahora me sale este error:

Building native extensions.  This could take a while...
Building nokogiri using packaged libraries.
ERROR:  Error installing nokogiri:
    ERROR: Failed to build gem native extension.

    /Users/zulhilmizainudin/.rvm/rubies/ruby-2.2.0/bin/ruby -r ./siteconf20151130-43942-1axq4sj.rb extconf.rb
Building nokogiri using packaged libraries.
-----
libiconv is missing.  please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
-----
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/zulhilmizainudin/.rvm/rubies/ruby-2.2.0/bin/$(RUBY_BASE_NAME)
    --help
    --clean
    --use-system-libraries
    --enable-static
    --disable-static
    --with-zlib-dir
    --without-zlib-dir
    --with-zlib-include
    --without-zlib-include=${zlib-dir}/include
    --with-zlib-lib
    --without-zlib-lib=${zlib-dir}/lib
    --enable-cross-build
    --disable-cross-build

extconf failed, exit code 1

Gem files will remain installed in /Users/zulhilmizainudin/.rvm/gems/ruby-2.2.0/gems/nokogiri-1.6.2.1 for inspection.
Results logged to /Users/zulhilmizainudin/.rvm/gems/ruby-2.2.0/extensions/x86_64-darwin-14/2.2.0-static/nokogiri-1.6.2.1/gem_make.out

Traté de seguir esta respuesta pero me sigue apareciendo el mismo error anterior.

Yo también trato de desinstalar e instalar de mi cerveza de nuevo (basado en esta respuesta) y sigue igual.

También, trato esta solución pero sigue apareciendo el error.

¿Qué debo hacer ahora para asegurarse de que esta nokogiri joya instalado correctamente?

Nota: estoy usando OSX 10.11.1 El Capitan.

  • ¿Tienes ya instalada xcode ? ¿Cuál es la salida del comando xcode-select --install ? También tiene que comprobar la nokogiri OSX instrucciones de instalación?
  • Sí, ya he instalar xcode y ejecutar xcode-select --install. Las herramientas de desarrollo xcode instalado correctamente.
  • Lo que llevó a todos a conocer el error involucrado xcode?

14 Kommentare

  1. 111

    De ejecutar estos comandos:

    gem uninstall nokogiri
    xcode-select --install
    gem install nokogiri

    fuente: http://www.nokogiri.org/tutorials/installing_nokogiri.html#mac_os_x

    a veces las actualizaciones de mac pueden romper xcode CLI para reinstalar puede solucionar el problema:
    https://github.com/sparklemotion/nokogiri/issues/1445

  2. 28

    Lo que funcionó para mí (en macOS Sierra) fue una combinación de La respuesta de Sam y las siguientes:

    gem install nokogiri -- --with-xml2-include=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/libxml2 --use-system-libraries
    • ese es el truco! Gracias
    • Esto funcionó para mí tratando de instalar nokogiri -v 1.8.0
    • He utilizado la misma cosa para instalar rails y funcionó! Gracias.
    • Esta trabajado con Mac Sierra Alta. Gracias!!.
    • esto funcionó para mí, sólo asegúrese de confirmar la carpeta porque el mío era /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.13.sdk/usr/include/libxml2
  3. 16

    Tuve un problema similar con 1.6.7.2 cuando bundle installing en codeship con ruby 2.3.

    Lo que funcionó para mí fue añadiendo:

    bundle config build.nokogiri --use-system-libraries

    antes de

    bundle install

    • Esta es la mejor manera de solucionar el problema en una solución más permanente. gem install nokogiri -v 1.6.6.2 — –use-sistema de bibliotecas
  4. 10

    Hice todo lo que en las otras respuestas, pero tenía que hacer una cosa más:

    1. Abrir Xcode
    2. Haga Clic En «Aceptar»
    3. Esperar un poco, cerca de Xcode
    4. Salve
  5. 5

    Parece que esto es debido a nokogiri 1.6.2.1 problema específico.

    Añado esta dentro de mi Gemfile:

    gem 'nokogiri', '~> 1.6', '>= 1.6.7'

    Y ejecutar bundle update nokogiri y, a continuación,bundle. Ahora todo funciona bien.

  6. 3

    Probar este

    sudo apt-get install build-essential patch ruby-dev zlib1g-dev liblzma-dev

    Y, a continuación, instalar Nokogiri

    sudo gem install nokogiri
  7. 2

    Spencer respuesta trabajado para mí, pero también me es necesario utilizar el parámetro-n para superar el problema de permisos documentado aquí.

    Así que al final, el comando que trabajó para mí fue:

    sudo gem install -n /usr/local/bin nokogiri -- --with-xml2-include=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/libxml2 --use-system-libraries
  8. 2

    También puede ser un problema con la anaconda versión de algunas de las bibliotecas.

    $ conda deactivate
    $ gem uninstall nokogiri
    $ gem install nokogiri
    $ conda activate base

    trabajó para mí.

  9. 0

    Tuve el problema similar. La razón era anticuado xcode.

    Si ejecuta brew doctor ustedes la pueden ver. Acaba de abrir AppStore, llegó a updates ficha y actualización de su xcode.

  10. 0

    Tuve el mismo problema al actualizar a xcode 10, lo resolvió con los siguientes pasos :

    1. xcode-seleccione –install
    2. bundle install –implementación de
    3. gem install nokogiri

Kommentieren Sie den Artikel

Bitte geben Sie Ihren Kommentar ein!
Bitte geben Sie hier Ihren Namen ein

Pruebas en línea