Actualmente estoy en el proceso de tratar de crear una función buscarv que se encargará de revisar la celda A2 y comprobar que en la hoja1. Si me trae un error, vaya a B2 y, a continuación, comprobar en la hoja1 y traer de vuelta los resultados.

Esto es lo que tengo actualmente:

=IF(ISNA(VLOOKUP(A2,'Sheet1'!$A$2:$A$1932,1,FALSE)),"0",VLOOKUP(B2,'Sheet1'!$A$2:$A$1932,1,FALSE))

Pero no parece traer de vuelta todos los resultados, es traer de vuelta algunos de los resultados de cada lista A2 y B2.

¿Qué estoy haciendo mal?

Gracias de antemano.

  • Si usted utilizar BUSCARV con ÍNDICE de columna de 1 a continuación, el resultado de la BUSCARV, si no es un error, es simplemente el valor de búsqueda en sí. No quieres un resultado de otra columna? Si es así, ¿cuál?
InformationsquelleAutor jagmitg | 2013-09-18

2 Comentarios

  1. 2

    Esto debería funcionar:

    =IFERROR(VLOOKUP(A2,'Sheet1'!$A$2:$A$1932,1,FALSE),VLOOKUP(B2,'Sheet1'!$A$2:$A$1932,1,FALSE))
    

    Utilizará A2 a y tratan de encontrar en la hoja1 y si se devuelve un error, se va a ir B2 y encontrar el elemento en la hoja1.

    • Otra forma sería utilizar COUNTIF así: =SI(COUNTIF(‘Hoja1’!$A$2:$A$1932,A2),A2,SI(COUNTIF(‘Hoja1’!$A$2:$A$1932,B2,B2,0))
  2. 2

    Trate de usar:

    =IF(ISNA(VLOOKUP(A2,'Sheet1'!$A$2:$A$1932,1,FALSE)),"0",VLOOKUP(A2,'Sheet1'!$A$2:$B$1932,2,FALSE))
    

    O puede utilizar un IFERROR para hacer las cosas más corto:

    =IFERROR(VLOOKUP(A2,'Sheet1'!$A$2:$B$1932,2,FALSE),"0")
    

    (Puede omitir las comillas alrededor de 0 si te refieres a un numérica 0 frente a un texto 0)

    Esta fórmula se obtiene el valor de la columna B en la Hoja1 utilizando el valor de búsqueda A2 de la Hoja2 y buscar en la columna a en la Hoja1.

    VLOOKUP comprueba el valor de A2 en la columna Sheet1!A:A y devuelve el valor de la columna Sheet1!B:B con la fórmula:

    =VLOOKUP(A2,'Sheet1'!$A$2:$B$1932,2,FALSE)
                               ^      ^
                               1      2
    
    1. B es el resultado de la columna

    2. 2 está en el índice relativo a A. a es la columna 1, B es la columna 2.


    EDICIÓN:

    Si usted desea obtener el valor de la columna de Un solo, comprobar el valor de la primera A2 y B2 en el fracaso de la primera, entonces usted puede utilizar:

    =IFERROR(VLOOKUP(A2,'Sheet1'!$A$2:$A$1932,1,FALSE),VLOOKUP(A2,'Sheet1'!$A$2:$A$1932,1,FALSE))
    
    • No hay 2 valores de búsqueda de Jerry? Supongo que debe ser algo como esto – =SI.ERROR(BUSCARV(A2,…..),SI.ERROR(BUSCARV(B2,…..),0))
    • Yo estaba bajo la impresión de OP fue en busca de obtener el valor de la columna B… creo que me fue mal 🙁
    • Podrías haber dicho que esto no era lo que estaba buscando y me hubiera hecho los cambios necesarios… Oh bien =/

Dejar respuesta

Please enter your comment!
Please enter your name here