Recientemente he adquirido un nuevo ordenador con windows instalado el php framework symfony.

Cuando intenta utilizar el comando nuevo C:> php symfony new blog puedo recibir el mensaje de error [GuzzleHttp\Ring\Exception\RingException] cURL error 60: SSL certificate problem: unable to get local issuer certificate.

Soy ni idea sobre qué hacer en este caso ya que no soy muy experimentado con el CMD de la interfaz.

Necesito saber si esto es un error con windows o con symfony y las posibles rutas que puede tomar en arreglarlo.

  • Hola colin tanto de @mokhtar-tlili sugerencias de trabajo por Favor marque la respuesta.
  • Esta respuesta puede ayudar a usted, aunque se trata de Wamp – stackoverflow.com/a/32095378/178163

3 Comentarios

  1. 78

    Siga este enlace, Copia de toda la página y guardarla en un: «cacert.pem«

    A continuación, en su php.ini archivo introduzca o modifique la línea siguiente: curl.cainfo = «[pathtothisfile]\cacert.pem»

    O

    uso compositor en lugar de Symfony instalador

    • He intentado copiar el .pem en la página y no tuvo éxito, pero con symfony todo había salido bien!
    • El compositor es la mejor solución para la instalación de la Symfony. Sólo utilice el comando composer create-project symfony/framework-standard-edition my_project_name "2.7.*" y puede correctamente instalado Symfony.
    • el compositor terminó trabajando gracias! Voy a ser lo que da como resultado compositor para la mayoría de tareas para los de ahora!
    • Su respuesta me ayudó a finalmente en «instalar» la maldita cosa. ¿Dónde puede una referencia a que se encuentra en su página web, todo lo que puedo ver es que algunos esqueleto toro (crear proyecto symfony/esqueleto blabla no me voy a trabajar) que de nuevo no funciona (a su manera es la única manera que funciona para mí) ?
  2. 4

    Tuve el mismo error con la versión de php 7.0.10

    El error que hice fue que me copyied el certificado (cacert.pem) en el mal php.ini archivo. Quiero decir, tengo 3 tipo de archivo ini: php-development.ini, php-production.ini y php.ini

    y la de la derecha fue php.ini

    Asegúrese de poner la ruta del certificado en la de la derecha.

    Y funcionará ! 😉
    precioso symfony <3

    FH

  3. 3

    usted puede tratar de la línea de comandos a continuación,se trabajó para mí

    composer create-project symfony/framework-standard-edition my_project_name "2.8.*"

Dejar respuesta

Please enter your comment!
Please enter your name here