Recibí el mensaje:

«cutilCheckMsg() CUTIL CUDA de error :

núcleo de lanzamiento de error : CUDA driver

la versión es insuficiente para CUDA

versión de tiempo de ejecución.»

Al intentar ejecutar un ejemplo de código fuente. También ocurre para la función cutilSafeCall.

Estoy usando:

  • Windows 7 64bits
  • Visual studio 2008
  • CUDA desarrollador conductor, kit de herramientas, y SDK 3.1
  • El modo de emulación de
  • Suena como que usted necesita para actualizar su controlador. Y es posible que desee hablar de lo que OS está utilizando, lo que CUDA SDK versión, etc.
  • Tenían el mismo mensaje…en mi caso había sido justo después de una actualización de windows, y el proceso de quita de Cuda Toolkit…simplemente requiere la reinstalación. Verificación de compatibilidad de versión. Aquí está mi trabajo conocido de configuración: Windows 10, de 64 bits, el cuda toolkit v9.0, Visual Studio 2015, Nvidia Quadro P4000, la versión de Python y en las librerías de Python 3.6.7, Tensorflow-gpu 1.13.1, Cudatoolkit 9.0, cudnn 7.1.4
InformationsquelleAutor superscalar | 2010-07-15

7 Comentarios

  1. 21

    Usted necesita para asegurarse de que su versión de controlador iguala o excede su CUDA Toolkit versión.

    2,3 usted necesita un 190.x controlador, para 3.0 necesita 195.x y 3.1 necesita 256.x (en realidad nada hasta el siguiente múltiplo de cinco años es de aceptar, por ejemplo, 258.x 3,1).

    Usted puede comprobar su versión del controlador ya sea ejecutando el deviceQueryDrv ejemplo de SDK o ir al Panel de Control de NVIDIA y elegir el Sistema de Información.

    Descarga de un controlador actualizado de http://www.nvidia.com/drivers.

  2. 5

    Usted puede descargar el controlador más reciente O uso un viejo kit de herramientas de la versión para compilar el código.

    • Usted también necesita asegurarse de que su include / biblioteca directorios punto a la versión correcta. He CUDA CUDA 5.5 y 6.0, e incluso cuando he cambiado la configuración de generación de utilizar el 5.5 compilador (en VS configuración del proyecto), que todavía estaba en silencio vinculación a 6.0 bibliotecas (en VS Opciones / C++ Directorios). Ahora funciona a la perfección. Tonto de mí …
  3. 3

    CUDA versión de controlador es insuficiente para CUDA runtime versión: significa que su GPU no ha sido manipulada por el CUDA runtime API, por lo que necesita para actualizar su controlador.

    • ¿Cómo se puede actualizar en las viudas?
    • sólo tienes que descargar la última versión e instalar
  4. 3

    Mi ciento,

    con Linux/Unix este error puede estar relacionado con el modo GPU (Rendimiento/Modo de Ahorro de Energía), cuando usted seleccione (con nvidia-settings utiliy) la GPU de Intel integrada y ejecutar el deviceQuery script… aparece este error:

    -> CUDA versión de controlador es insuficiente para CUDA runtime, versión

    Pero este error es engañosa, seleccionando de nuevo el NVIDIA(modo de funcionamiento) con nvidia-settings utility el problema desaparece.

    No es un problema de versión.

    Que respecta a

    P. s: «Modo de Ahorro de Energía» dice Optimus para activar la CPU GPU de Intel integrada

  5. 0

    También he tenido un problema similar, actualizado mi controlador de gráficos, pero el problema sigue siendo. Finalmente me decidí a quitar Cuda 9.2 e instalar Cuda 8, solucionó mi problema.

Dejar respuesta

Please enter your comment!
Please enter your name here