La semana pasada traté de depuración con SSL activado en webbrick, pero me olvido de cómo restaurar la configuración por defecto(sin SSL). Cada vez que visita un controlador, ahora se muestra:

Error de conexión SSL
No puede establecer una conexión segura con el servidor. Esto puede ser un problema con el servidor, o puede ser que requiera un certificado de autenticación de cliente que usted no tiene.
El Error 107 (net::ERR_SSL_PROTOCOL_ERROR): protocolo SSL error.

Y a continuación es el log de la consola, alguien puede ayudar?

[2011-05-10 07:28:43] INFO WEBrick 1.3.1
[2011-05-10 07:28:43] INFO ruby 1.8.7 (2009-06-12) [universal-darwin10.0]
[2011-05-10 07:28:43] INFO WEBrick::HTTPServer#inicio: pid=62854 port=3000
[2011-05-10 07:28:58] ERROR bad Request-Line `UQM?x?ʾ???????c??B?????n???BU???*???98?5EDf32?A/??’.

  • trate de seguir las instrucciones que aparecen en este blog: nearinfinity.com/blogs/chris_rohr/…
  • ¿Alguna vez has averiguar esto? Me obligó a SSL, corrió en un error, se quitó toda la fuerza de código SSL y ahora me sale nada pero error con mi aplicación… Webrick debe ser la celebración en la configuración? ¿Cómo se puede borrar?
InformationsquelleAutor Howard Huang | 2011-05-09

4 Comentarios

  1. 29

    Sólo me encontré con este mismo problema hoy en día. He añadido config.force_ssl = true a la aplicación.rb archivo y consiguió el error anterior. Cuando me quité la línea, el error aún persiste.

    Me fijo por la eliminación de las cookies de mi navegador (Chrome, en este caso) y funciona de nuevo. Parece que la autenticación de la información se guarda en una cookie y algo que me mantiene revertir nuestras peticiones HTTPS pero no se autentica correctamente para recibir ese error. Borrar la cookie soluciona ese problema.

    • trabajó para mí…gracias
  2. 22

    Tuve un problema similar, pero no era capaz de solucionarlo desactivando las cookies en Chrome (ni ninguno de los otros arreglos como rake tmp:clear), y terminó de conmutación para el uso de finas con SSL habilitado, como se sugiere en este post:

    https://stackoverflow.com/a/11614213

    Añadido esto a mi Gemfile:

    group :development do
       gem "thin"
    end

    Luego bundle y thin start --ssl.

    • Ya he utilizado delgada y comencé a obtener el error de ssl. Entonces me encontré con el comando sugerido y le dijo al navegador a confiar en el servidor de todos modos. Entonces, dejé el servidor y regresó con «rails s». Se volvió a la normalidad. Gracias. Por cierto… he tenido este error de ssl con chrome (firefox se sigue trabajando).
  3. 3

    Tuve que usar rake tmp:sessions:clear (no sólo rake:tmp:clear) así como borrar las cookies en el navegador para solucionar este problema.

    • pequeña corrección => rake tmp:clear
  4. 0

    Igualmente he recibido el mismo mensaje de error después de la adición de config.force_ssl = true en mi config/locales/aplicación.rb archivo

    Para remediar un error de SSL, basta con editar Rails.application.config.session_store :cookie_store, key: '_app_sessions' en config/inicializadores/session_store.rb

    Cambiar el '_app_sessions' nombre a cualquier otra cosa que te permitirá empezar tu servidor rails sin ssl y sin error

Dejar respuesta

Please enter your comment!
Please enter your name here