He PyCharm 1.5.4 y han utilizado el «Open Directory» opción para abrir el contenido de una carpeta en el IDE.

Tengo la versión de Python 3.2 seleccionado (se muestra bajo el «Bibliotecas Externas» nodo).

Cómo puedo seleccionar otra versión de Python (que ya tengo instalado en mi máquina), de modo que PyCharm utiliza esa versión en su lugar?

6 Comentarios

  1. 148

    Archivo -> Configuración de

    Preferencias->Proyecto de Intérprete->Python Intérpretes

    Si no aparece agregarlo.

    Cómo seleccionar la versión de Python en PyCharm?

    • ¿Por qué tiene upvotes como no contestar la pregunta. Él dice que se ha instalado varias versiones de Python (versión 2 y versión 3). Él quiere ejecutar algunos scripts con python 3 y algunos con python 2. ¿Cómo se puede cambiar la versión de python que se utiliza?
    • Es en Archivo->Ajustes->proyecto de intérprete en las versiones más recientes.
    • Y aún más reciente (por ejemplo. 4.5.4 y hasta está en Archivo -> Ajustes -> Proyecto: {your_project_name} -> Proyecto de Intérprete .
  2. 24

    Creo que usted está diciendo que usted tiene python2 y python3 instalado y he añadido una referencia a cada versión de bajo Pycharm > Configuraciones > Proyecto de Intérprete

    Lo que creo que estás preguntando es, ¿cómo tener algunos de los proyectos que se ejecutan con Python 2 y algunos de los proyectos que se ejecutan con Python 3.

    Si es así, puedes buscar en Ejecutar > Editar las Configuraciones de

    Cómo seleccionar la versión de Python en PyCharm?

    • Esto funcionará para ejecutar la secuencia de comandos, pero es que realmente significaba para los que realmente se ejecuta de la intérprete y puede incluso ser ajustado en cada clase. Hay un proyecto de configuración de todo el que mejor encaja.
  3. 4

    Esto también puede ocurrir en Intellij Ultimate, que ha PyCharm integrado. El problema es diagnosticado anteriormente, usted tiene el mal intérprete seleccionado.

    El método exacto para arreglar esto para cualquier proyecto es ir a Configuración del ProyectoProyecto y ajustar el Proyecto SDK. Usted puede agregar un Nuevo Proyecto SDK si usted no tiene Python 3 añadido por desplazarse a la python3 binario. Este va a corregir los errores enumerados anteriormente. Un acceso directo a la Configuración del Proyecto es el azul del tablero de ajedrez-tipo de icono.

    También puede agregar Python 3 como el valor predeterminado, el intérprete de Python proyectos. En OSX, esto es en Archivo..Otros AjustesDefecto Estructura del Proyecto. No se puede establecer la Proyecto SDK que ahora se aplicará en cada nuevo proyecto. Puede ser diferente en otras plataformas, pero todavía similar.

  4. 4

    PyCharm 2019.1+

    Hay una nueva característica llamada Intérprete en la barra de estado (desplácese hacia abajo un poco). Esto hace que la conmutación entre los intérpretes de python y ver qué versión estás usando más fácil.

    Cómo seleccionar la versión de Python en PyCharm?

    Habilitar la barra de estado

    En caso de que usted no puede ver la barra de estado, usted puede fácilmente activar mediante la ejecución de la Acción de comando (Ctrl+Cambio+Un o + +Un en mac). A continuación, escriba barra de estado y elegir Vista: la Barra de Estado a ver.

    Cómo seleccionar la versión de Python en PyCharm?

  5. 3

    Ir a:

    Files -> Settings -> Project -> *"Your Project Name"* -> Project Interpreter

    Allí se puede ver que las bibliotecas externas que se han instalado para python2 y que para python3.

    Seleccione la versión de python de acuerdo a sus necesidades.

    Cómo seleccionar la versión de Python en PyCharm?

  6. 2

    Respuesta Rápida:

    • File –> Setting
    • En el lado izquierdo en project sección –> Project interpreter
    • Seleccionar Project interpreter
    • Aplicar + ACEPTAR

    [NOTA]:

    Probado en Pycharm 2018 2017.


Dejar respuesta

Please enter your comment!
Please enter your name here