Estoy recibiendo constantemente la

Cannot fetch index base URL https://pypi.python.org/simple/

siempre trato de pip instalar nada con el más reciente pip versión.

He leído en algunas otras preguntas que pip estaba teniendo SSL relacionados con problemas en su última versión y recomienda instalar pip 1.2.1.

¿Cómo puedo instalar una versión específica de pip a través de easy_install por ejemplo?

InformationsquelleAutor currysensei | 2014-09-19

3 Comentarios

  1. 16

    Usted debería ser capaz de instalar pip con el pip:

    pip install --upgrade pip==1.2.1
    • He intentado la solución, pero me sigue apareciendo el mismo error, como se mencionó en la pregunta =\. Hay una manera de instalar pip a través de otro gestor de paquetes para eludir el error de SSL?
    • Para mí, pip 1.5.5 funciona bien en mavericks, así que no estoy seguro de que el problema está causado por un problema con 1.5.5. Sin embargo, no te ves en este MODO de respuesta: stackoverflow.com/questions/21294997/… ? Usted puede tratar de seguir los pasos que recomienda.
    • usted sabe que usted puede ser verdaderamente llamado un salvavidas por algunos..
  2. 1

    Basado en su contexto, puede desinstalar como el anterior y, a continuación, ejecute:

    sudo easy_install pip==1.2.1

    No más molestos SSL errores.

  3. 0

    Desinstale cualquier versión anterior a la instalación de pip. Teniendo en cuenta que están utilizando en todo el sistema de instalación,

    sudo apt-get remove python-pip

    y también,

    pip uninstall pip

    Ahora,

    sudo apt-get install python-setuptools
    sudo easy_install pip==<specific version>
    sudo pip install virtualenv

    Es la preferida para el uso virtual environment aunque.

    • Estoy en Mavericks, y aunque esto funciona en mi ubuntu vm, todavía no resuelve mi problema: que es para instalar pip 1.2.1 en Mac OS X Mavericks. Por supuesto, estoy asumiendo que el apt-get es un Linux sólo el administrador de paquetes. Gracias 🙂
    • usted puede utilizar brew en mac.

Dejar respuesta

Please enter your comment!
Please enter your name here