Presentar el problema

Me gustaría saber si estamos utilizando la API de Web 1 o 2. Mis propios paquetes.config indica la versión 5.0.0. Es que en la Web de la API de 1 o 2?

De búsqueda, de investigación y

He tratado de buscar en Google lo siguiente:

«de la web de la api de 1», «web api 2»

y

ASP.NET Web de la versión de la API de la historia

y

ASP.NET API Web de nuget

Las mejores referencias parecen ser estos dos nuget páginas:

¿Es eso cierto? ¿Cómo puedo saber con seguridad?

InformationsquelleAutor Shaun Luttin | 2014-05-06

3 Comentarios

  1. 29

    Creo que lo que se encuentra parece correcta. Yo tenía la misma pregunta, a continuación, tenía una mirada en mis paquetes instalados que cuando usted vaya a «Administrar paquetes de Nuget». Hubo un elemento instalado con el nombre de «Microsoft ASP.NET WEB de la API de 2.2». Así que yo era capaz de determinar mi propia versión a partir de ahí.

    • Buscando en Administrar Paquetes de NuGet es una buena idea.
    • en VS2015, usted puede comprobar los paquetes.archivo de configuración de la versión.
    • El título de el paquete de NuGet muestra el número de versión: nuget.org/packages/Microsoft.AspNet.WebApi
  2. 17

    No estoy seguro de lo @Juan quería decir con el nombre del paquete anterior. Estoy teniendo el siguiente paquete ahora mismo:

    Microsoft.AspNet.WebApi.5.2.3

    Basado en este artículo http://www.asp.net/web-api/overview/releases/whats-new-in-aspnet-web-api-22 supongo que a partir de la versión del paquete 5.2.2 Web de la API de la versión 2.2.

    • Odio que, compruebe el archivo de paquetes y se dice que es la versión 5, pero en realidad es la versión 2, no me gusta esto de las versiones infierno
    • Mismo aquí, v5.2.3. Gracias!
    • El artículo: «la última ASP.NET Web API 2.2 paquete tiene la siguiente versión: ‘5.2.0’»
  3. 12

    Yo siempre trato de este lugar –

    En el controlador de crear un método de

    public IHttpActionResult MyResult(){
        return Ok();
    }

    Si usted consigue error de compilación, a continuación, es la API 1.0.

    Si no hay ningún error de compilación, a continuación, se hace referencia a la API 2.0.

Dejar respuesta

Please enter your comment!
Please enter your name here