¿Cómo puedo instalar APCu en Windows?

He encontrado este. Pero necesito una solución para Windows.

Yo uso PHP 5.5.6 (yo tengo el paquete XAMPP).

stackoverflow.com/questions/8682729/…
Me refiero a apcu. No apc. Desde php5.5 necesita apcu
Hola user3481997! Robert respuesta es la correcta. La única diferencia para usted es que usted está usando XAMPP. En mi caso, la carpeta para copiar el «correcto» dll «C:\xampp\php\ext». Su XAMPP directorio puede ser diferente. Revise su registro de error de PHP para asegurarse de que se instala correctamente.

OriginalEl autor user3481997 | 2014-06-27

4 Comentarios

  1. 44

    Este corto y directo al punto tutorial debe ayudar a

    Instalar APCu en Windows

    Supuestos

    • Supongo que usted sabe lo que es APC – Alternative PHP cache
    • Desea instalar APCu porque APC no es compatible ya con PHP 5.5.x
    • Desea instalar APCu para wamp, xampp. La mayoría de windows web plataformas de desarrollo para PHP

    Instrucciones

    Pre: Todas las ubicaciones de directorio puede ser diferente dependiendo de su carpeta de instalación de wamp y su PHP/apache versiones.

    1. Ir a http://pecl.php.net/package/APCu, hay una tabla con las versiones disponibles
    2. Escoger la versión que mejor se adapte a (última versión estable que apoye su versión de php)
    3. Elija el paquete de DLL lista, dependiendo de cuál de Windows que esté utilizando:
      • Versión de PHP (5.5 en su caso)
      • x64 (64 bits) O x86 (de 32 bits de windows)
      • Hilo Fuerte (para la compatibilidad con Apache)
    4. Descomprimir el archivo, copiar php_apcu.dll en C:\wamp\bin\php\php5.5.6\ext.
    5. Ir a C:\wamp\bin\apache\apache2.4.9\bin abrir php.ini y agregar las siguientes líneas (acabo de añadir al final del archivo):

      [apcu]
      extension=php_apcu.dll
      apc.enabled=1
      apc.shm_size=32M
      apc.ttl=7200
      apc.enable_cli=1
      apc.serializer=php

      Esta son las configuraciones recomendadas encuentra en el archivo de INSTALACIÓN de la php_apcu archivo, a excepción de la ubicación del archivo DLL.

    6. Reiniciar wamp

    7. Ir a http://localhost/phpinfo.php y comprobar si apcu tabla de configuración aparece y apcu está habilitado
    8. Si también desea utilizar apcu para PHP CLI, a continuación, sólo tiene que añadir en C:\wamp\bin\php\php5.5.6\bin\php.ini la configuración de líneas que agregó en el paso 5 en apache php.ini.

    El final!

    Mientras que este vínculo puede responder a la pregunta, es mejor incluir a las partes esenciales de la respuesta aquí y proporcionar el enlace de referencia. Enlace-sólo respuestas puede ser válido si la página enlazada cambios.
    De hecho @Maks3w, gracias! 🙂

    OriginalEl autor Robert

  2. 6

    Para aquellos que quieren APCu con versiones anteriores de APC de compatibilidad (1:1 reemplazo sin cambiar el código fuente, por ejemplo apc_cache_info > apcu_cache_info)

    1. Descarga php_apcu.dll de página de lanzamiento (elegir la correcta versión de PHP, la arquitectura y el hilo a modo de seguridad)

    2. Descarga php_apcu_bc.dll de PECL

    3. Guardar ambos archivos en ext dir en virtud de su instalación de PHP carpeta

    4. De carga de extensiones en php.ini:

      extension=php_apcu.dll
      extension=php_apcu_bc.dll
    5. Configurar APCu en php.ini

      [APCu]
      apc.enabled=1
      apc.shm_size=32M
      apc.ttl=7200
      apc.enable_cli=1
      apc.serializer=php

    INFO: APC extensión con APCu-BC 1.0.3 debe llamarse exactamente php_apcu.dll con el fin de trabajar. Cuando me llamó php_apcu_bc-1.0.3-7.1-ts-vc14-x86.dll XAMPP no se inicia correctamente (error acerca de la falta de php_apc.dll)

    Nota adicional: el archivo zip descargado de la fuente de arriba para vc15 contiene un archivo llamado php_apc.dll (en el archivo: ‘php_apcu_bc-1.0.4-7.2-ts-vc15-x86.zip’ fecha: 13/06/2018) – acaba de cambiar el nombre a php_apcu_bc.dll trabajó.

    OriginalEl autor Wirone

  3. 0

    Por favor refiérase a la documentación oficial:

    https://secure.php.net/manual/en/opcache.installation.php

    En mi caso, estoy utilizando PHP 5.6 en XAMPP
    y todo lo que necesita hacer es actualizar mi php.ini archivo con (configuración recomendada):

    opcache.memory_consumption=128
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=4000
    opcache.revalidate_freq=60
    opcache.fast_shutdown=1
    opcache.enable_cli=1

    OriginalEl autor Ivan

  4. -3

    Descarga el .archivo dll de aquí

    Editar el php.archivo ini y agregar la siguiente línea en la sección de extensiones:

    extension = php_apc.dll
    Me refiero a apcU. No apc.

    OriginalEl autor Jenno Richi Benat

Dejar respuesta

Please enter your comment!
Please enter your name here