Si me quedo curl google.com, no veo la salida, sólo una página en blanco. Mi Vagrantfile contiene:

Vagrant.configure("2") do |config|
  config.vm.box = "trumobi"
 #config.vm.box_url = "http://192.168.136.129/package.box"
  config.ssh.default.username = "trumobi"
  config.vm.network :public_network
  config.vm.network :forwarded_port, host: 8000, guest: 8000
end
InformationsquelleAutor user2439278 | 2013-08-27

4 Comentarios

  1. 62

    Si usted está usando Vagrant + VirtualBox + Ubuntu, es posible que desee agregar el siguiente bloque a su VagrantFile:

    config.vm.provider "virtualbox" do |v|
        v.customize ["modifyvm", :id, "--natdnshostresolver1", "on"]
        v.customize ["modifyvm", :id, "--natdnsproxy1", "on"]
    end
    

    Si usted está usando ubuntu, y usted piensa que su firewall está on, he aquí cómo desactivar el firewall:

    sudo ufw disable
    
    • después de agregar los comentarios anteriores en mi vagrantfile, im que enfrentan el mismo problema. Cuando doy curl http://www.google.com, i cant capaz de ver la salida de la señal. Sólo en blanco de la pantalla se muestran. A continuación encontrará la actualización de la vagrantfile.
    • Vagrant.configure("2") do |config| config.vm.box = "trumobi" #config.vm.box_url = "http://192.168.136.129/package.box" config.ssh.default.username = "trumobi" config.vm.network :public_network config.vm.network :forwarded_port, host: 8000, guest: 8000 config.vm.provider "virtualbox" do |v| v.customize ["modifyvm", :id, "--natdnshostresolver1", "on"] v.customize ["modifyvm", :id, "--natdnsproxy1", "on"] end end
    • después de un largo tiempo que lanza un error:curl: (7) no pudo conectar al host
    • Usted puede ser que desee comprobar la configuración de firewall de su vagrant cuadro.
    • podría usted por favor ayuda me a comprobarlo. Soy nuevo en este vagabundo
    • Estoy usando Ubuntu 12.04
    • Retirada de este enlace: askubuntu.com/questions/250775/…
    • he comprobado en mi terminal , ufw status sólo se deshabilita. Ahora también enfrentan el mismo problema
    • Creo que user2439278 no ejecutar vagrant reload después de agregar la configuración sugerida para el Vagrantfile: solucionado el problema para mí.
    • funciona bien después de su lanzamiento vagrant reload --provision
    • funciona en la máquina donde vagabunda que se está ejecutando. Pero cuando traté en otro sistema, no su trabajo. Por favor me ayude a solucionar este problema
    • Gracias! Este solucionado todos mis problemas en Ubuntu 14.04
    • Perfecto para mí, así como en Ubuntu 14.04
    • Tenía el mismo problema en Mac OSX, esto funciona!

  2. 32

    Esto sucede a veces para mí, si puedo cambiar el host de la conexión de red, como la desconexión de mi portátil cable Ethernet y empezar a utilizar la red inalámbrica.
    He encontrado que reiniciar el Vagrant vm (vagrant halt, vagrant up) arregla las cosas.

    • Buena llamada. Gracias!
    • eso es exactamente lo que trato de primera y más a menudo se arregla como: ¿has probado a apagar y a encender de nuevo?
    • Al parecer, esto también puede suceder en un Windows (Server Core 2016) VM cuando mi laptop duerme y se despierta de nuevo. Gracias por la sugerencia!
  3. 4

    Deshabilitar el firewall me ayudó.
    En mi CentOS invitado cuadro que hice:

    # sudo service iptables save
    # sudo service iptables stop
    # sudo chkconfig iptables off
    
    • La mejor respuesta!
  4. 4

    He intentado todo sin éxito (Vagrant+Virtualbox+Ubuntu 14.04). Virtualbox estaba mostrando Adaptador de 1 (NAT): cable desconectado». Agregando lo siguiente a mi Vagrantfile arreglado:

    config.vm.provider 'virtualbox' do |vb|
      vb.customize ['modifyvm', :id, '--cableconnected1', 'on']
    end
    

    Encontrar aquí: https://github.com/mitchellh/vagrant/issues/7648

Dejar respuesta

Please enter your comment!
Please enter your name here