Necesito para ejecutar eclipse(java 1.7) y STS 3.8.1 ( java 1.8), pero si puedo elegir el java 7 como predeterminado estoy recibiendo el error en el PTS 3.8.1.
Estoy usando OS : ubuntu 14.10

Error  : Version 1.7.0_80 of the JVM is not suitable for this product. Version: 1.8 or greater is required.

O puedo elegir java 1.8 como predeterminado eclipse no está funcionando bien.

Mi requisito es crear un Proyecto utilizando java 1.7 with STS. y la última versión 3.8.1 no compatibles con java 1.7.

y yo tratamos de buscar que version of STS support 1.7 pero no estoy recibiendo ninguna respuesta .

Si sólo necesita el Java 7 para la construcción de un Proyecto, puede Cambiar la Versión de Java dentro de su eclipse/PTS sólo para este Proyecto en las propiedades del Proyecto
Consulte stackoverflow.com/questions/12588537/… para más información

OriginalEl autor Prabhat Yadav | 2016-09-29

5 Comentarios

  1. 6

    Esta pregunta es viejo, pero para cualquier persona mirando este en el futuro que no se puede instalar Java 8 o de lo contrario no se puede utilizar la solución en la otra respuesta – 3.8.0 fue la primera versión que requieren Java 1.8, mientras que 3.7.3 todavía juega bonito, con sólo Java 1.7.

    Esto ayuda mucho.

    OriginalEl autor meowseph_furbalin

  2. 3

    Si usted llegó a esta página porque ha buscado el mismo error, pero quería una opción diferente, usted puede tratar de actualizar el PTS.ini opciones de configuración (por ejemplo, en /pts-win32-x86_64/pts-bundle/pts-3.9.3.RELEASE/carpeta) con dos líneas en la parte superior de la siguiente manera. La segunda línea es el camino a Java 8 de instalación.

    -vm
    C:/Program Files/Java/jdk1.8.0_131/bin/javaw.exe

    Original:

    -startup
    plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    --launcher.library
    plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
    -product
    org.springsource.sts.ide
    --launcher.defaultAction
    openFile
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    --add-modules=ALL-SYSTEM
    -Xms40m
    -Dosgi.module.lock.timeout=10
    -Dorg.eclipse.swt.browser.IEVersion=10001
    -Xmx1200m

    Actualizado:

    -vm
    C:/Program Files/Java/jdk1.8.0_131/bin/javaw.exe
    -startup
    plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    --launcher.library
    plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
    -product
    org.springsource.sts.ide
    --launcher.defaultAction
    openFile
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    --add-modules=ALL-SYSTEM
    -Xms40m
    -Dosgi.module.lock.timeout=10
    -Dorg.eclipse.swt.browser.IEVersion=10001
    -Xmx1200m

    OriginalEl autor behold

  3. 1

    Está pidiendo jdk 1.8 para abrir y ejecutar el PTS (eclipse). Todavía le permiten construir su proyecto de código/con lo JDK versión que desee.

    Instalar jdk1.8, establece su JAVA_HOME y la RUTA de acceso env variables para que 1.8 se convierte en su defecto jdk. Después de esto usted debe ser capaz de abrir PTS. A continuación, el programa de instalación del proyecto y el conjunto del proyecto JDK 1.7 o lo que quieras.

    Espero te sirva de ayuda.

    Esto ayuda mucho.

    OriginalEl autor Rakesh Prajapati

  4. 0

    El PTS 3.8.1 todo-en-uno de la distribución está basada en Eclipse v4.6, que requiere de Java 1.8 a empezar.
    Como @Jens se mencionó, puede Abrir Windows -> Preferences. A continuación, abra nodo de árbol Java > Installed JREs. Después de la adición de un nuevo JRE/JDK, se puede establecer como predeterminado o eliminar otros elementos.

    Otra opción: si tiene instalado Eclipse, 4.5, por favor visite https://spring.io/tools/sts/all

    1. Instalar PTS 3.8.1 a través de Actualización de Sitios: abrir Help -> Install New Software.... Sólo tienes que pegar la actualización de la dirección URL del sitio en el Asistente.
    2. Si prefieres instalarlo en línea, usted puede descargar PTS Sitio de Actualización de Archivos. Haciendo clic en el Add... botón en el mismo Asistente, seleccione la carpeta de archivo zip descomprimido.

    OriginalEl autor Beck Yang

Dejar respuesta

Please enter your comment!
Please enter your name here