Cuando ejecuto $ javac Simulator.java luego me sale la siguiente advertencia:

warning: ./particle_simulator/Atom.class: major version 51 is newer than 50, the highest major version supported by this compiler.

No sé por qué de repente me aparece esta advertencia como no he hecho cambios importantes en mi código. Sin embargo, ¿cómo puedo actualizar mi compilador de Java?

Estoy ejecutando Mac OSX 10.7.5 y mi versión de Java es la siguiente:

java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
Vaya A la sitio Web de Oracle y descargar
Acerca de la Actualización de Java para Mac OS X v10.3.9 support.apple.com/kb/ts1537 referencia doc .

OriginalEl autor Eric Baldwin | 2013-11-22

1 Comentario

Dejar respuesta

Please enter your comment!
Please enter your name here