Primero de todo, me puse la generación del Proyecto de Destino en proyecto\propiedades\android.
He creado AVD con el Nivel 7 y 8 con APIs de Google, establezca cada uno de los AVD sólo la tarjeta SD de tamaño de 4 gb, establecer el min versión de SDK a 7 el objetivo del SDK de a 8 en el archivo de Manifiesto. Sin éxito.
Puedo eliminar todas las AVD y recrear.

Después de que yo vuelva a instalar Eclipse Rcp, Instalado ADT en Eclipse, y se ha Instalado el SDK de Android, y crear AVDs de nuevo.

Mi aplicación GPS es funcionaba bien sin APIs de Google, en la anterior versión que tengo actualmente implementado una vista para mostrar tracklog en MapView mi app no funciona.

El DDMS no mostrar nunca el eclipse.

¿Cómo puedo solucionar este error?

[2012-03-26 09:27:50 - GPS] Installation error: INSTALL_FAILED_MISSING_SHARED_LIBRARY
[2012-03-26 09:27:50 - GPS] Please check logcat output for more details.
[2012-03-26 09:27:51 - GPS] Launch canceled!

Aquí es el LogCat de registro de error:

03-26 07:26:22.220: E/vold(27): Error opening switch name path '/sys/class/switch/test' (No such file or directory)
03-26 07:26:22.220: E/vold(27): Error bootstrapping switch '/sys/class/switch/test' (No such file or directory)
03-26 07:26:22.220: E/vold(27): Error opening switch name path '/sys/class/switch/test2' (No such file or directory)
03-26 07:26:22.220: E/vold(27): Error bootstrapping switch '/sys/class/switch/test2' (No such file or directory)
03-26 07:27:03.399: E/BatteryService(66): usbOnlinePath not found
03-26 07:27:03.399: E/BatteryService(66): batteryVoltagePath not found
03-26 07:27:03.399: E/BatteryService(66): batteryTemperaturePath not found
03-26 07:27:03.420: E/SurfaceFlinger(66): Couldn't open /sys/power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake
03-26 07:27:27.730: E/EventHub(66): could not get driver version for /dev/input/mouse0, Not a typewriter
03-26 07:27:27.730: E/EventHub(66): could not get driver version for /dev/input/mice, Not a typewriter
03-26 07:27:28.440: E/System(66): Failure starting core service
03-26 07:27:28.440: E/System(66): java.lang.SecurityException
03-26 07:27:28.440: E/System(66):   at android.os.BinderProxy.transact(Native Method)
03-26 07:27:28.440: E/System(66):   at android.os.ServiceManagerProxy.addService(ServiceManagerNative.java:146)
03-26 07:27:28.440: E/System(66):   at android.os.ServiceManager.addService(ServiceManager.java:72)
03-26 07:27:28.440: E/System(66):   at com.android.server.ServerThread.run(SystemServer.java:176)
03-26 07:27:28.440: E/AndroidRuntime(66): Crash logging skipped, no checkin service
03-26 07:27:39.779: E/ActivityThread(120): Failed to find provider info for android.server.checkin
03-26 07:27:41.341: E/ActivityThread(120): Failed to find provider info for android.server.checkin
03-26 07:27:41.530: E/ActivityThread(120): Failed to find provider info for android.server.checkin
03-26 07:27:42.060: E/ActivityThread(120): Failed to find provider info for android.server.checkin
03-26 07:27:42.140: E/ActivityThread(120): Failed to find provider info for android.server.checkin
03-26 07:27:49.890: E/PackageManager(66): Package com.lkv.mobile.apps.gps requires unavailable shared library com.google.android.maps; failing!
03-26 07:27:50.331: E/AndroidRuntime(163): ERROR: thread attach failed
referencia: stackoverflow.com/questions/2283398/…
es correcto, ese es el camino a seguir.

OriginalEl autor Laszlo | 2012-03-26

3 Comentarios

  1. 13

    Comprobar su Manifest.xml. En mi caso fue:

        <uses-library android:name="com.google.android.maps" />
    

    que tuve que quitar.

    Si estás trabajando con Mapas V2, entonces usted no necesita com.google.android.mapas
    Estoy teniendo el mismo problema. Si puedo modificar el manifiesto, no puedo probar mi mapa de características. Hay una manera de instalar google maps paquete en el emulador (AVD)?
    Supongo que usted está tratando de implementar Maps V2, V1 no. Entonces es parte de la Play Services framework. En el emulador debería funcionar sin problema. Lo AVD estás usando??
    Sí, V2. Es un 4.2 no-Nexus (MDPI). Acerca de las listas de la versión del kernel como 2.6.29-gea447bb ([email protected]#1); Modelo de SDK

    OriginalEl autor IgorGanapolsky

  2. 1

    En un dispositivo real para solucionar el fixing missing shared library, en algunas roms el comp.google.android.map no está presente.

    download googleapps
    extract two files
    system/etc/permissions/com.google.android.maps.xml
    system/framework/com.google.android.maps.jar
    remount the /system filesystem rw (mount -o rw,remount /system)
    copy the files in
    do a chmod 644 on them
    reboot
    

    Todos los créditos a @Nys

    OriginalEl autor Siddharth

  3. 0

    mina TRABAJADO en emulador en la depuración cuando me muevo utiliza la biblioteca de la etiqueta de «aplicación» del elemento.

    uses-library android:name=com.google.android.maps
    

    En modo de lanzamiento de sus pidiendo a estar en el interior de «aplicación», no sé por qué.

    OriginalEl autor user5626078

Dejar respuesta

Please enter your comment!
Please enter your name here