Me estoy enfrentando el siguiente error:

Error:(89, 39) error: incomparable types: CAP#1 and int  
where CAP#1 is a fresh type-variable:  
CAP#1 extends Object from capture of ?Note: Some input files use unchecked or   unsafe operations.  
Note: Recompile with -Xlint:unchecked for details.  
Error:Execution failed for task ':app:compileDebugJava'.  

Compilación error; ver el error del compilador de salida para obtener más detalles.

Mi Gradle Archivo tiene el siguiente aspecto:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.0 rc3"

    repositories {
        maven { url "https://jitpack.io" }
        mavenCentral()
        jcenter()

    }

    defaultConfig {
        applicationId "wishlist.oj.app"
        minSdkVersion 16
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:23.0.0'
    compile 'com.android.support:recyclerview-v7:21.+'
    compile 'com.android.support:cardview-v7:21.+'
}

El error viene de Mi Reciclador de Vista Adaptador de Archivo que sólo infla el varias textviews en recycler ver

InformationsquelleAutor ojas | 2015-12-28

2 Comentarios

  1. 5

    De Error:error en la Ejecución de la tarea ‘:app:compileDebugJava’.

    Para La Buena Práctica

    A primera habilitar multiDexEnabled ,a Continuación, actualizar su support:recyclerview ,support:appcompat ,support:cardview versión

    El Android plugin de Gradle disponible en el SDK de Android de Herramientas de construcción
    21.1 y superior soporta multidex como parte de la configuración de generación. Asegúrese de actualizar el SDK de Android Construir Herramientas y Android
    Apoyo Repositorio a la última versión usando el SDK Manager antes de
    intentando configurar la aplicación para multidex.

    La configuración de su aplicación el desarrollo del proyecto para usar un multidex configuración requiere que realizar unas modificaciones en el desarrollo de la aplicación del proyecto. En particular, usted necesita realizar los siguientes pasos:

    1. Cambiar su Gradle configuración de compilación para activar multidex
    2. Modificar el manifiesto para hacer referencia a la MultiDexApplication clase

    Modificar su aplicación Gradle construir archivo de configuración para incluir el apoyo de la biblioteca y habilitar multidex de salida .

         android {
            compileSdkVersion 23
            buildToolsVersion "23.0.1"
    
            defaultConfig {
                ...
                minSdkVersion 16
                targetSdkVersion 23
                ...
    
                //Enabling multidex support.
                multiDexEnabled true
            }
            ...
        }
    
        dependencies {
          compile 'com.android.support:multidex:1.0.0'
          compile 'com.android.support:appcompat-v7:23.1.1'
          compile 'com.android.support:recyclerview-v7:23.1.1"
          compile 'com.android.support:cardview-v7:23.1.1'
         }

    Luego Limpieza De Reconstrucción De Reiniciar La Sincronización De Su Proyecto

    • mismo error persiste.. ¿qué cambios necesito hacer en el archivo de manifiesto de android?
    • mismo logcat devuelve ??
    • puede establecer buildToolsVersion "23.0.2" ¿Cuál es tu classpath ?
    • el uso de classpath 'com.android.tools.build:gradle:1.5.0' ?
    • donde debo escribir en el classpath. De los que no puedo escribir esto en las dependencias. buildToolsVersion «23.0.2» no era útil….mi gradle versión : 2.2.1 .. android plugin de la versión:1.2.2 … ¿tengo que actualizar algo?
  2. 2

    Cambio

    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:recyclerview-v7:23.1.1"
    compile 'com.android.support:cardview-v7:23.1.1'
    • He aplicado la solución…junto con los anteriores errores error nuevo vino: Nota: C:\Users\AndroidStudioProjects\WishList\app\src\main\java\oj\app\home\AdaptorDrawer.java los usos o anula en desuso de la API.

Dejar respuesta

Please enter your comment!
Please enter your name here